fwfh_webview 0.14.8 copy "fwfh_webview: ^0.14.8" to clipboard
fwfh_webview: ^0.14.8 copied to clipboard

Platformweb

WidgetFactory extension to render IFRAME with the official WebView plugin.

33
likes
140/ 140
pub points
97%
popularity

We analyzed this package 7 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

59 out of 66 API elements (89.4 %) have documentation comments.

Some symbols that are missing documentation: fwfh_webview, fwfh_webview.WebViewFactory.buildAnchorBodyItem, fwfh_webview.WebViewFactory.customStylesBuilder, fwfh_webview.WebViewFactory.customWidgetBuilder, fwfh_webview.WebViewFactory.onTapAnchor.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Web

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:fwfh_webview/fwfh_webview.dart that imports:
  • package:fwfh_webview/src/web_view_factory.dart that imports:
  • package:fwfh_webview/src/web_view/web_view.dart that imports:
  • package:fwfh_webview/src/web_view/io.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:fwfh_webview/fwfh_webview.dart that imports:
  • package:fwfh_webview/src/web_view_factory.dart that imports:
  • package:fwfh_webview/src/web_view/web_view.dart that imports:
  • package:fwfh_webview/src/web_view/io.dart that imports:
  • package:webview_flutter_android/webview_flutter_android.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:fwfh_webview/fwfh_webview.dart that imports:
  • package:fwfh_webview/src/web_view_factory.dart that imports:
  • package:fwfh_webview/src/web_view/web_view.dart that imports:
  • package:fwfh_webview/src/web_view/io.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `Linux`.

Because:

  • package:fwfh_webview/fwfh_webview.dart that imports:
  • package:fwfh_webview/src/web_view_factory.dart that imports:
  • package:fwfh_webview/src/web_view/web_view.dart that imports:
  • package:fwfh_webview/src/web_view/io.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `macOS`.

Because:

  • package:fwfh_webview/fwfh_webview.dart that imports:
  • package:fwfh_webview/src/web_view_factory.dart that imports:
  • package:fwfh_webview/src/web_view/web_view.dart that imports:
  • package:fwfh_webview/src/web_view/io.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_widget_from_html_core >=0.10.5 <0.15.0 0.14.11 0.14.11
logging ^1.0.0 1.2.0 1.2.0
webview_flutter ^4.0.1 4.7.0 4.7.0
webview_flutter_android ^3.10.0 3.16.0 3.16.0
webview_flutter_wkwebview ^3.6.0 3.13.0 3.13.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
csslib - 1.0.0 1.0.0
html - 0.15.4 0.15.4
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
term_glyph - 1.2.1 1.2.1
vector_math - 2.1.4 2.1.4
webview_flutter_platform_interface - 2.10.0 2.10.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.