fvm 3.1.7 copy "fvm: ^3.1.7" to clipboard
fvm: ^3.1.7 copied to clipboard

A simple cli to manage Flutter SDK versions per project. Support channels, releases, and local cache for fast switching between versions.

fvm #

GitHub stars Pub Version Pub Likes Pub Points All Contributors MIT License Codecov Awesome Flutter

FVM streamlines Flutter version management. It allows per project SDK versions, ensuring consistent app builds and easier testing of new releases, thereby boosting the efficiency of your Flutter project tasks.

Why FVM? #

  • Need for simultaneous use of multiple Flutter SDKs.
  • SDK testing requires constant channel switching.
  • Channel switches are slow and need repeated reinstalls.
  • Difficulty managing the latest successful SDK version used in an app.
  • Flutter's major updates demand total app migration.
  • Inconsistencies occur in development environments within teams.

For more information, read FVM documentation.

Contributors #


Checkout Flutter Sidekick. Read more about it here.

Troubleshooting #

Please view our FAQ.

License #

This project is licensed under the MIT License; see LICENSE file for details.

570
likes
140
pub points
90%
popularity

Publisher

verified publisherleoafarias.com

A simple cli to manage Flutter SDK versions per project. Support channels, releases, and local cache for fast switching between versions.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

args, cli_completion, dart_console, dart_mappable, date_format, git, interact, io, jsonc, mason_logger, meta, path, pub_semver, pub_updater, pubspec, scope, stack_trace, tint, yaml

More

Packages that depend on fvm