freezed 0.12.7
freezed: ^0.12.7 copied to clipboard

Dart native

Code generation for immutable classes that has a simple syntax/API without compromising on the features.

620
likes
90 / 110
pub points
95 %
popularity

We analyzed this package on Feb 24, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 2 API elements (50.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:freezed/builder.dart that imports:
  • package:freezed/src/freezed_generator.dart that imports:
  • package:freezed/src/templates/from_json_template.dart that imports:
  • package:freezed/src/models.dart that imports:
  • package:freezed/src/templates/prototypes.dart that imports:
  • package:freezed/src/templates/parameter_template.dart that imports:
  • package:freezed/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.40.4 <1.0.00.41.21.0.0
build>=0.12.6 <2.0.01.6.21.6.3
build_config>=0.4.2 <1.0.00.4.60.4.6
freezed_annotation>=0.12.0 <2.0.00.12.00.12.0
meta>=1.2.0 <2.0.01.2.41.3.0
source_gen^0.9.00.9.10+30.9.10+3
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.016.0.0
args-1.6.02.0.0
async-2.4.22.5.0
charcode-1.1.31.2.0
checked_yaml-1.0.41.0.4
cli_util-0.2.00.3.0
collection-1.14.131.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
dart_style-1.3.121.3.13
file-5.2.16.1.0
glob-1.2.02.0.0
intl-0.16.10.17.0
js-0.6.20.6.3
logging-0.11.41.0.0
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
path-1.7.01.8.0
pedantic-1.9.21.10.0
pub_semver-1.4.42.0.0
pubspec_parse-0.1.80.1.8
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.2.01.3.0
watcher-0.9.7+151.0.0
yaml-2.2.13.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.40.4 <1.0.0` on analyzer does not support the latest published version `1.0.0`

pubspec.yaml:12:13

   ╷
12 │   analyzer: '>=0.40.4 <1.0.0'
   │             ^^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Dart 2.10.5.

620
likes
90
pub points
95%
popularity

Publisher

dash-overflow.net

Code generation for immutable classes that has a simple syntax/API without compromising on the features.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, build, build_config, freezed_annotation, meta, source_gen

More

Packages that depend on freezed