fontsource 0.4.0 copy "fontsource: ^0.4.0" to clipboard
fontsource: ^0.4.0 copied to clipboard

Easily add Fontsource fonts to your flutter app. Includes a dart interface for the Fontsource API.

10
likes
120/ 140
pub points
30%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

8 out of 23 API elements (34.8 %) have documentation comments.

Some symbols that are missing documentation: api, api.FontMetadata.category, api.FontMetadata.defSubset, api.FontMetadata.family, api.FontMetadata.id.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The import of 'dart:ui' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/fontsource.dart:1:8

  ╷
1 │ import 'dart:ui';
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/fontsource.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
http ^0.13.4 0.13.6 1.2.1
json2yaml ^3.0.0 3.0.1 3.0.1
path ^1.8.0 1.9.0 1.9.0
progress_bar ^1.0.0 1.0.0 1.0.0
version ^3.0.0 3.0.2 3.0.2
yaml ^3.1.0 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.4` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Flutter 3.19.0, Dart 3.3.0.

Check the analysis log for details.

10
likes
120
pub points
30%
popularity

Publisher

verified publisherfontsource.org

Easily add Fontsource fonts to your flutter app. Includes a dart interface for the Fontsource API.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, http, json2yaml, path, progress_bar, version, yaml

More

Packages that depend on fontsource