fnx_rest 4.1.1 copy "fnx_rest: ^4.1.1" to clipboard
fnx_rest: ^4.1.1 copied to clipboard

Angular and Flutter friendly RestClient, which will make your communication with REST APIs much simpler.

10
likes
120/ 160
pub points
29%
popularity

We analyzed this package 1 hour ago, and awarded it 120 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

OUT: Documenting fnx_rest... Discovering libraries... Linking elements... Precaching local docs for 159294 elements... Initialized dartdoc with 208 libraries Generating docs for library fnx_rest_io.dart from package:fnx_rest/fnx_rest_io.dart... Generating docs for library fnx_rest.dart from package:fnx_rest/fnx_rest.dart... Generating docs for library fnx_rest_browser.dart from package:fnx_rest/fnx_rest_browser.dart... Documented 3 public libraries in 26.7 seconds ERR: warning: ambiguous reexport of rest_listing.UnpackedData, canonicalization candidates: (fnx_rest, fnx_rest, fnx_rest) -> fnx_rest (confidence 0.000) from rest_listing.UnpackedData: (file:///tmp/pana_BIOQGS/lib/src/rest_listing.dart:139:7) fnx_rest: 1.210 - (_Reason.packageName (+1.000), _Reason.longName (+0.01000), _Reason.sharedNamePart (+0.2000)) fnx_rest: 1.210 - (_Reason.packageName (+1.000), _Reason.longName (+0.01000), _Reason.sharedNamePart (+0.2000)) fnx_rest: 1.210 - (_Reason.packageName (+1.000), _Reason.longName (+0.01000), _Reason.sharedNamePart (+0.2000)) Use {@canonicalFor rest_listing.UnpackedData} in the desired library's documentation to resolve the ambiguity and/or override dartdoc's decision, or structure your package so the reexport is less ambiguous. The symbol will still be referenced in all candidates -- this only controls the location where it will be written and which library will be [130 more lines]

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

WARNING: Unnecessary type check; the result is always 'true'.

lib/src/rest_client.dart:394:7

    ╷
394 │   if (payload is String) {
    │       ^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/rest_client.dart

INFO: The import of 'package:http/src/response.dart' is unnecessary because all of the used elements are also provided by the import of 'package:http/http.dart'.

lib/fnx_rest_io.dart:19:8

   ╷
19 │ import 'package:http/src/response.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/fnx_rest_io.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
http >=0.12.0 <1.0.0 0.13.6 1.2.1
logging any 1.2.0 1.2.0
pedantic ^1.9.0 1.11.1 1.11.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.12.0 <1.0.0` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

10
likes
120
pub points
29%
popularity

Publisher

verified publisherfnx.io

Angular and Flutter friendly RestClient, which will make your communication with REST APIs much simpler.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

http, logging, pedantic

More

Packages that depend on fnx_rest