flx_ui 2.9.4 copy "flx_ui: ^2.9.4" to clipboard
flx_ui: ^2.9.4 copied to clipboard

UI widgets designed in Flx UI style

2
likes
70/ 160
pub points
0%
popularity

We analyzed this package 23 hours ago, and awarded it 70 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://flx.pub was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: GPL-3.0.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

268 out of 499 API elements (53.7 %) have documentation comments.

Some symbols that are missing documentation: color_theme, color_theme.ColorTheme, color_theme.ColorTheme.ColorTheme, color_theme.ColorTheme.accent, color_theme.ColorTheme.background.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flx_ui/flx_ui.dart that imports:
  • package:flx_ui/widgets/widgets.dart that imports:
  • package:flx_ui/widgets/target/target.dart that imports:
  • package:flx_ui/widgets/target/controllers/target_controller.dart that imports:
  • package:vibration/vibration.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flx_ui/flx_ui.dart that imports:
  • package:flx_ui/widgets/widgets.dart that imports:
  • package:flx_ui/widgets/target/target.dart that imports:
  • package:flx_ui/widgets/target/controllers/target_controller.dart that imports:
  • package:vibration/vibration.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:flx_ui/flx_ui.dart that imports:
  • package:flx_ui/widgets/widgets.dart that imports:
  • package:flx_ui/widgets/target/target.dart that imports:
  • package:flx_ui/widgets/target/controllers/target_controller.dart that imports:
  • package:vibration/vibration.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flx_ui/flx_ui.dart that imports:
  • package:flx_ui/widgets/widgets.dart that imports:
  • package:flx_ui/widgets/target/target.dart that imports:
  • package:flx_ui/widgets/target/controllers/target_controller.dart that imports:
  • package:vibration/vibration.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:flx_ui/flx_ui.dart that imports:
  • package:flx_ui/widgets/widgets.dart that imports:
  • package:flx_ui/widgets/target/target.dart that imports:
  • package:flx_ui/widgets/target/controllers/target_controller.dart that imports:
  • package:vibration/vibration.dart that imports:
  • package:vibration_platform_interface/vibration_platform_interface.dart that imports:
  • package:vibration_platform_interface/src/method_channel_vibration.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:flx_ui/flx_ui.dart that imports:
  • package:flx_ui/widgets/widgets.dart that imports:
  • package:flx_ui/widgets/target/target.dart that imports:
  • package:flx_ui/widgets/target/controllers/target_controller.dart that imports:
  • package:vibration/vibration.dart that imports:
  • package:vibration_platform_interface/vibration_platform_interface.dart that imports:
  • package:vibration_platform_interface/src/method_channel_vibration.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 39 issues. Showing the first 2:

ERROR: The getter 'accentColor' isn't defined for the type 'ThemeData'.

lib/themes/color_theme.dart:14:39

   ╷
14 │     return material.Theme.of(context).accentColor;
   │                                       ^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/themes/color_theme.dart

ERROR: The getter 'headline6' isn't defined for the type 'TextTheme'.

lib/themes/text_theme.dart:5:49

  ╷
5 │     return material.Theme.of(context).textTheme.headline6!;
  │                                                 ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/themes/text_theme.dart

failed
Support up-to-date dependencies
20 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
get ^4.1.4 4.6.6 4.6.6
vibration ^1.7.4-nullsafety.0 1.9.0 1.9.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
device_info_plus - 10.1.0 10.1.0
device_info_plus_platform_interface - 7.0.0 7.0.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
vibration_platform_interface - 0.0.1 0.0.1
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
win32_registry - 1.1.3 1.1.3

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 35 errors:

  • UNDEFINED_GETTER - lib/themes/color_theme.dart:14:39 - The getter 'accentColor' isn't defined for the type 'ThemeData'.
  • UNDEFINED_GETTER - lib/themes/text_theme.dart:5:49 - The getter 'headline6' isn't defined for the type 'TextTheme'.
  • UNDEFINED_GETTER - lib/themes/text_theme.dart:9:49 - The getter 'subtitle1' isn't defined for the type 'TextTheme'.

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

2
likes
70
pub points
0%
popularity

Publisher

verified publisherflx.pub

UI widgets designed in Flx UI style

Homepage

Documentation

API reference

License

GPL-3.0 (LICENSE)

Dependencies

flutter, get, vibration

More

Packages that depend on flx_ui