flutter_zoekits 1.0.0
flutter_zoekits: ^1.0.0 copied to clipboard

A Flutter kits for Zoe.

0
likes
60/ 130
pub points
11%
popularity

We analyzed this package on Nov 28, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.
The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 45 out of 350 API elements (12.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:flutter_zoekits/flutter_zoekits.dart that imports:
  • package:flutter_zoekits/src/utils/platform.dart that imports:
  • package:imei_plugin/imei_plugin.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 34 issues. Showing the first 2:

lib/flutter_zoekits.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/extensions/background.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
device_info_plus^1.0.11.0.13.1.1
flutterflutter0.0.00.0.0
flutter_form_builder^6.0.16.2.07.0.0
flutter_zoewebview^1.0.01.1.01.1.0
imei_plugin^1.2.01.2.01.2.0
package_info_plus^1.0.11.3.01.3.0
shared_preferences^2.0.62.0.92.0.9
shimmer^2.0.02.0.02.0.0
velocity_x^3.2.03.3.03.3.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
auto_size_text_pk-3.0.03.0.0
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
device_info_plus_linux-1.0.12.1.0
device_info_plus_macos-1.0.12.2.0
device_info_plus_platform_interface-1.0.22.2.1
device_info_plus_web-1.0.12.1.0
device_info_plus_windows-1.0.12.1.0
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_inappwebview-5.3.25.3.2
flutter_localizations-0.0.00.0.0
flutter_web_plugins-0.0.00.0.0
flutter_webview_plugin-0.4.00.4.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
intl-0.17.00.17.0
js-0.6.30.6.3
meta-1.7.01.7.0
package_info_plus_linux-1.0.31.0.3
package_info_plus_macos-1.3.01.3.0
package_info_plus_platform_interface-1.0.21.0.2
package_info_plus_web-1.0.41.0.4
package_info_plus_windows-1.0.41.0.4
path-1.8.01.8.0
path_provider_linux-2.1.22.1.2
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
shared_preferences_android-2.0.92.0.9
shared_preferences_ios-2.0.82.0.8
shared_preferences_linux-2.0.32.0.3
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.22.0.2
shared_preferences_windows-2.0.32.0.3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
vxstate-2.1.02.1.0
webview_flutter-2.3.12.3.1
webview_flutter_android-2.3.12.3.1
webview_flutter_platform_interface-1.5.11.5.1
webview_flutter_wkwebview-2.4.02.4.0
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.1` on device_info_plus does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions device_info_plus to update the constraint.

The constraint `^6.0.1` on flutter_form_builder does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions flutter_form_builder to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.