flutter_widget_from_html_core 0.5.2 icon indicating copy to clipboard operation
flutter_widget_from_html_core: ^0.5.2 copied to clipboard

Flutter package for widget tree building from html that focuses on correctness and extensibility.

193
likes
100/ 130
pub points
98%
popularity

We analyzed this package 6 days ago, and awarded it 100 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 241 out of 249 API elements (96.8 %) have documentation comments.
icon indicating section status
Platform Support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:flutter_widget_from_html_core/flutter_widget_from_html_core.dart that imports:
  • package:flutter_widget_from_html_core/src/core_widget_factory.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because mockito >=4.0.0 <4.1.1+1 depends on test_api ^0.2.1 and mockito >=4.1.1+1 <4.1.2 depends on test_api >=0.2.1 <0.4.0, mockito >=4.0.0 <4.1.2 requires test_api >=0.2.1 <0.4.0.
And because network_image_mock <1.1.0 depends on mockito ^4.1.1 and network_image_mock ^1.1.0 depends on mockito ^4.1.3, network_image_mock <2.0.0 requires test_api >=0.2.1 <0.4.0 or mockito ^4.1.2.
And because mockito >=4.1.2 <=5.0.0-nullsafety.7 depends on test_api ^0.2.19-nullsafety and every version of flutter_test from sdk depends on test_api 0.4.3, flutter_test from sdk is incompatible[...]
So, because flutter_widget_from_html_core depends on both flutter_test from sdk and network_image_mock ^1.0.1, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.5, Flutter 2.8.1, Dart 2.15.1.

193
likes
100
pub points
98%
popularity

Publisher

shield icon for verified publishersdaohoangson.com

Flutter package for widget tree building from html that focuses on correctness and extensibility.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, html

More

Packages that depend on flutter_widget_from_html_core