flutter_widget_from_html_core 0.4.0-rc.2020043001 icon indicating copy to clipboard operation
flutter_widget_from_html_core: ^0.4.0-rc.2020043001 copied to clipboard

Flutter plugin for widget tree building from html that focuses on correctness and extensibility.

194
likes
80/ 130
pub points
98%
popularity

We analyzed this package 27 days ago, and awarded it 80 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 23 out of 252 API elements (9.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Support multiple platforms
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/src/core_widget_factory.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/ops/style_direction.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
html^0.14.0+30.14.0+40.15.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.0
collection-1.15.01.15.0
csslib-0.16.20.17.1
meta-1.7.01.7.0
path-1.8.11.8.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.12.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.14.0+3` on html does not support the stable version `0.15.0`.

Try running dart pub upgrade --major-versions html to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0-dev.68.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.8.0, Dart 2.15.0.

194
likes
80
pub points
98%
popularity

Publisher

shield icon for verified publishersdaohoangson.com

Flutter plugin for widget tree building from html that focuses on correctness and extensibility.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

flutter, html

More

Packages that depend on flutter_widget_from_html_core