flutter_widget_from_html 0.5.0-rc.2020071301

Flutter package for widget tree building from html that supports hyperlink, image, nested list, etc.

102
likes
50 / 100
pub points
97 %
popularity

We analyzed this package on Oct 19, 2020, and awarded it 50 pub points (of a possible 100):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 10

10/10 points: Package has an example

  • Found example at: example/main.dart
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_widget_from_html/flutter_widget_from_html.dart that imports:
  • package:flutter_widget_from_html/src/widget_factory.dart that imports:
  • package:flutter_widget_from_html/src/html_widget.dart that imports:
  • package:flutter_widget_from_html/src/helpers.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:flutter_widget_from_html/flutter_widget_from_html.dart that imports:
  • package:flutter_widget_from_html/src/widget_factory.dart that imports:
  • package:flutter_widget_from_html/src/html_widget.dart that imports:
  • package:flutter_widget_from_html/src/helpers.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:flutter_widget_from_html/flutter_widget_from_html.dart that imports:
  • package:flutter_widget_from_html/src/widget_factory.dart that imports:
  • package:flutter_widget_from_html/src/html_widget.dart that imports:
  • package:flutter_widget_from_html/src/helpers.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:flutter_widget_from_html/flutter_widget_from_html.dart that imports:
  • package:flutter_widget_from_html/src/widget_factory.dart that imports:
  • package:flutter_widget_from_html/src/html_widget.dart that imports:
  • package:flutter_widget_from_html/src/helpers.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:flutter_widget_from_html/flutter_widget_from_html.dart that imports:
  • package:flutter_widget_from_html/src/widget_factory.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:cached_network_image/src/image_provider/_image_provider_io.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/web/web_helper.dart that imports:
  • package:flutter_cache_manager/src/cache_store.dart that imports:
  • package:flutter_cache_manager/src/config/config.dart that imports:
  • package:flutter_cache_manager/src/config/_config_io.dart that imports:
  • package:flutter_cache_manager/src/storage/file_system/file_system_io.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform iOS

Because:

  • package:flutter_widget_from_html/flutter_widget_from_html.dart that imports:
  • package:flutter_widget_from_html/src/widget_factory.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:cached_network_image/src/image_provider/_image_provider_io.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/web/web_helper.dart that imports:
  • package:flutter_cache_manager/src/cache_store.dart that imports:
  • package:flutter_cache_manager/src/config/config.dart that imports:
  • package:flutter_cache_manager/src/config/_config_io.dart that imports:
  • package:flutter_cache_manager/src/storage/file_system/file_system_io.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 32 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:flutter_widget_from_html_core/src/builder.dart'.

lib/src/builder.dart:1:8

  ╷
1 │ export 'package:flutter_widget_from_html_core/src/builder.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/builder.dart

ERROR: The named parameter 'onPieces' isn't defined.

lib/src/ops/tag_a_extended.dart:5:9

  ╷
5 │         onPieces: (meta, pieces) {
  │         ^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/ops/tag_a_extended.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^2.2.0+12.3.32.3.3
chewie^0.9.100.9.100.9.10
flutterflutter0.0.00.0.0
flutter_layout_grid^0.10.20.10.20.10.2
flutter_svg>=0.17.4 <0.19.00.18.10.19.0
flutter_widget_from_html_core^0.5.0-rc.20200713010.5.1+30.5.1+3
html^0.14.0+30.14.0+40.14.0+4
url_launcher^5.4.105.7.55.7.5
video_player^0.10.11+10.10.12+50.11.1+2
webview_flutter^0.3.22+10.3.241.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0-nullsafety.3
charcode-1.1.31.2.0-nullsafety.1
clock-1.0.11.1.0-nullsafety.1
collection-1.15.0-nullsafety.31.15.0-nullsafety.3
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
ffi-0.1.30.1.3
file-5.2.15.2.1
flutter_blurhash-0.5.00.5.0
flutter_cache_manager-2.0.02.0.0
flutter_web_plugins-0.0.00.0.0
http-0.12.20.12.2
http_parser-3.1.43.1.4
intl-0.16.10.16.1
matcher-0.12.90.12.10-nullsafety.1
meta-1.3.0-nullsafety.31.3.0-nullsafety.4
octo_image-0.3.00.3.0
open_iconic_flutter-0.3.00.3.0
path-1.7.01.8.0-nullsafety.1
path_drawing-0.4.1+10.4.1+1
path_parsing-0.1.40.1.4
path_provider-1.6.211.6.21
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+40.0.4+4
path_provider_platform_interface-1.0.31.0.3
path_provider_windows-0.0.4+10.0.4+1
petitparser-3.1.03.1.0
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
quiver-2.1.32.1.3
rxdart-0.24.10.24.1
sky_engine-0.0.990.0.99
source_span-1.7.01.8.0-nullsafety.2
sqflite-1.3.1+11.3.1+1
sqflite_common-1.0.2+11.0.2+1
stack_trace-1.9.51.10.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.1
synchronized-2.2.0+22.2.0+2
term_glyph-1.1.01.2.0-nullsafety.1
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.3
url_launcher_linux-0.0.1+10.0.1+1
url_launcher_macos-0.0.1+80.0.1+8
url_launcher_platform_interface-1.0.81.0.8
url_launcher_web-0.1.4+10.1.4+1
url_launcher_windows-0.0.1+10.0.1+1
uuid-2.2.22.2.2
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.3
video_player_platform_interface-2.2.02.2.0
video_player_web-0.1.40.1.4
wakelock-0.1.4+20.2.0+1
win32-1.7.31.7.3
xdg_directories-0.1.20.1.2
xml-4.5.14.5.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `>=0.17.4 <0.19.0` on flutter_svg does not support the latest published version `0.19.0`

pubspec.yaml:17:16

   ╷
17 │   flutter_svg: ">=0.17.4 <0.19.0"
   │                ^^^^^^^^^^^^^^^^^^
   ╵
The constraint `^0.10.11+1` on video_player does not support the latest published version `0.11.1+2`

pubspec.yaml:21:17

   ╷
21 │   video_player: ^0.10.11+1
   │                 ^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs