flutter_uploadcare 0.1.0+1
flutter_uploadcare: ^0.1.0+1 copied to clipboard

Flutter integration for uploadcare.

0
likes
55 / 130
pub points
9 %
popularity

We analyzed this package on May 7, 2021, and awarded it 55 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

No `README.md` found.

The README.md file should inform others about your project, what it does, and how they can use it. See: the example generated by stagehand.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 6 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:flutter_uploadcare/flutter_uploadcare.dart that imports:
  • package:flutter_uploadcare/src/cdn_path_builder_extension.dart that imports:
  • package:uploadcare/uploadcare.dart that imports:
  • package:uploadcare/src/cdn_client.dart that imports:
  • package:restio/restio.dart that imports:
  • package:restio/src/retrofit/result.dart that imports:
  • package:restio/src/core/request/header/headers.dart that imports:
  • package:restio/src/core/request/header/headers_builder.dart that imports:
  • package:restio/src/core/request/header/header.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Unused import: 'dart:ui'.

lib/src/cdn_path_builder_extension.dart:1:8

  ╷
1 │ import 'dart:ui';
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/cdn_path_builder_extension.dart

INFO: Avoid using braces in interpolation when not needed.

lib/src/cdn_path_builder_extension.dart:46:39

   ╷
46 │     sb.write('/-/resize/${widthPixel}x${heightPixel}');
   │                                       ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/cdn_path_builder_extension.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
freezed_annotation>0.7.1 <1.0.00.14.10.14.1
uploadcare^0.2.00.2.0+10.2.0+1
Transitive dependencies
PackageConstraintCompatibleLatest
brotli-0.3.0+10.5.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
equatable-1.2.62.0.0
fixnum-0.10.111.0.0
globbing-0.3.11.0.0
http-0.12.20.13.3
http2-1.0.12.0.0
http_parser-3.1.44.0.0
intl-0.16.10.17.0
ip-0.1.10.1.1
json_annotation-4.0.14.0.1
matcher-0.12.100.12.10
meta-1.3.01.3.0
mime_type-0.3.21.0.0
path-1.8.01.8.0
raw-0.2.00.2.0
restio-0.10.110.10.11
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
utf-0.9.0+50.9.0+5
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.