flutter_uploadcare 0.1.0

0.1.0 #

  • uploadcare 0.2.0

0.0.1 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_uploadcare: ^0.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_uploadcare/flutter_uploadcare.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
37
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
30
Overall:
Weighted score of the above. [more]
54
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • flutter_uploadcare that is a package requiring null.

Package not compatible with runtime flutter-web on web

Because:

  • package:flutter_uploadcare/flutter_uploadcare.dart that imports:
  • package:flutter_uploadcare/src/cdn_path_builder_extension.dart that imports:
  • package:uploadcare/uploadcare.dart that imports:
  • package:uploadcare/src/cdn_client.dart that imports:
  • package:restio/restio.dart that imports:
  • package:restio/src/retrofit/result.dart that imports:
  • package:restio/src/core/request/header/headers.dart that imports:
  • package:restio/src/core/request/header/headers_builder.dart that imports:
  • package:restio/src/core/request/header/header.dart that imports:
  • dart:io

Health issues and suggestions

Document public APIs. (-1 points)

6 out of 6 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/cdn_path_builder_extension.dart. (-1 points)

Analysis of lib/src/cdn_path_builder_extension.dart reported 2 hints:

line 1 col 8: Unused import: 'dart:ui'.

line 46 col 39: Avoid using braces in interpolation when not needed.

Maintenance issues and suggestions

Provide a file named README.md. (-30 points)

The README.md file should inform others about your project, what it does, and how they can use it. See the example generated by stagehand.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (freezed_annotation).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_uploadcare.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
freezed_annotation ^0.7.1 0.7.1 0.11.0
uploadcare ^0.2.0 0.2.0
Transitive dependencies
brotli 0.3.0+1
charcode 1.1.3
collection 1.14.12 1.14.13
convert 2.1.1
crypto 2.1.5
equatable 1.2.0
fixnum 0.10.11
globbing 0.3.1
http 0.12.1
http2 1.0.0
http_parser 3.1.4
intl 0.16.1
ip 0.1.1
json_annotation 3.0.1
matcher 0.12.8
meta 1.1.8 1.2.2
mime_type 0.3.2
path 1.7.0
raw 0.2.0
restio 0.10.5
sky_engine 0.0.99
source_span 1.7.0
stack_trace 1.9.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
utf 0.9.0+5
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
build_runner ^1.10.0
flutter_test
freezed ^0.10.8
mockito ^4.1.1
pedantic ^1.9.0 1.9.0 1.9.2
test ^1.14.3