flutter_upayments 1.0.2 copy "flutter_upayments: ^1.0.2" to clipboard
flutter_upayments: ^1.0.2 copied to clipboard

The UPayments flutter SDK allows you to integrate easily and faster with native Android and iOS apps. Manage your transactions and clients effectively and in real-time through our easy-to-use real-tim [...]

7
likes
110/ 160
pub points
72%
popularity

We analyzed this package 9 hours ago, and awarded it 110 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: flutter_upayments,
    • contains a version property, and,
    • does not contain a publish_to property.

Could not find any pubspec.yaml in the repository.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 27 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: flutter_upayments, flutter_upayments.RequestPayment, flutter_upayments.paymentDetails, flutter_upayments.paymentDetails.apiKey, flutter_upayments.paymentDetails.currencyCode.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_upayments/flutter_upayments.dart that imports:
  • package:flutter_upayments/src/upayments.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:flutter_upayments/flutter_upayments.dart that imports:
  • package:flutter_upayments/src/upayments.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:flutter_upayments/flutter_upayments.dart that imports:
  • package:flutter_upayments/src/upayments.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Web`.

Because:

  • package:flutter_upayments/flutter_upayments.dart that imports:
  • package:flutter_upayments/src/upayments.dart that imports:
  • package:flutter_upayments/src/upaymentDialog.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:flutter_upayments/flutter_upayments.dart that imports:
  • package:flutter_upayments/src/upayments.dart that imports:
  • package:flutter_upayments/src/upaymentDialog.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:flutter_upayments/flutter_upayments.dart that imports:
  • package:flutter_upayments/src/upayments.dart that imports:
  • package:flutter_upayments/src/upaymentDialog.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_android/webview_surface_android.dart that declares support for platforms: Android.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 31 issues. Showing the first 2:

WARNING: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: upayDialog.data, upayDialog.weblink, upayDialog.OnSuccess, upayDialog.OnFailure

lib/src/upaymentDialog.dart:6:7

  ╷
6 │ class upayDialog extends StatefulWidget {
  │       ^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/upaymentDialog.dart

WARNING: The value of the local variable 'dialogContext' isn't used.

lib/src/upayments.dart:116:16

    ╷
116 │   BuildContext dialogContext;
    │                ^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/upayments.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_bcrypt ^1.0.7 1.0.8 1.0.8
fluttertoast ^8.0.8 8.2.6 8.2.6
http ^0.13.4 0.13.6 1.2.1
webview_flutter ^3.0.0 3.0.4 4.8.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.1.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
webview_flutter_android - 2.10.4 3.16.4
webview_flutter_platform_interface - 1.9.5 2.10.0
webview_flutter_wkwebview - 2.9.5 3.13.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.4` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^3.0.0` on webview_flutter does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions webview_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

7
likes
110
pub points
72%
popularity

Publisher

verified publisherupayments.com

The UPayments flutter SDK allows you to integrate easily and faster with native Android and iOS apps. Manage your transactions and clients effectively and in real-time through our easy-to-use real-time dashboard. We provide a powerful, secure payment and pre-built UI that can be used out-of-the-box to collect your users payment details. This pre-built UI lets you accept KNET, Apple Pay, Samsung Pay, Visa and MasterCard.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_bcrypt, fluttertoast, http, webview_flutter

More

Packages that depend on flutter_upayments