flutter_unity_cli 1.0.6 icon indicating copy to clipboard operation
flutter_unity_cli: ^1.0.6 copied to clipboard

A command-line application for managing flutter unity at scale.

2
likes
80/ 130
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 80 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 38 API elements (34.2 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:flutter_unity_cli/flutter_unity_cli.dart that imports:
  • package:flutter_unity_cli/src/modules/modules.dart that imports:
  • package:flutter_unity_cli/src/modules/version.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 24 issues. Showing the first 2:

INFO: The import of 'package:flutter_unity_cli/src/modules/version.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter_unity_cli/flutter_unity_cli.dart'.

bin/main.dart:4:8

  ╷
4 │ import 'package:flutter_unity_cli/src/modules/version.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze bin/main.dart

INFO: Unused import: 'package:flutter_unity_cli/src/utils/file_utils.dart'.

lib/src/command/command_base.dart:3:8

  ╷
3 │ import 'package:flutter_unity_cli/src/utils/file_utils.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/command/command_base.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ansicolor^1.0.21.1.12.0.1
args^1.6.01.6.02.3.1
dart_console^0.6.10.6.21.1.2
http^0.12.10.12.20.13.5
path^1.7.01.8.21.8.2
pub_semver^1.4.41.4.42.1.1
pubspec_yaml^2.0.12.0.1+13.1.0
recase^3.0.03.0.14.0.0
tuple^1.0.31.0.32.0.0
version^1.2.01.3.13.0.2
yaml^2.2.12.2.13.1.1
yaml_modify^0.1.30.1.41.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.16.01.16.0
ffi-0.1.32.0.1
functional_data-0.3.01.0.0
http_parser-3.1.44.0.1
json2yaml-1.0.1+13.0.0
matcher-0.12.120.12.12
meta-1.8.01.8.0
pedantic-1.11.11.11.1
plain_optional-0.1.31.0.0
quiver-2.1.53.1.0
source_span-1.9.11.9.1
stack_trace-1.10.01.10.0
string_scanner-1.1.11.1.1
sum_types-0.2.1+20.3.2
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
win32-1.7.4+12.7.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 11 issues. Showing the first 2:

The constraint `^1.0.2` on ansicolor does not support the stable version `2.0.1`.

Try running dart pub upgrade --major-versions ansicolor to update the constraint.

The constraint `^1.6.0` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.8.1 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.15, Dart 2.17.6.

2
likes
80
pub points
0%
popularity

Publisher

verified publisher iconxraph.com

A command-line application for managing flutter unity at scale.

Homepage

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

ansicolor, args, dart_console, http, path, pub_semver, pubspec_yaml, recase, tuple, version, yaml, yaml_modify

More

Packages that depend on flutter_unity_cli