flutter_ui_toolkit 0.0.3+9 copy "flutter_ui_toolkit: ^0.0.3+9" to clipboard
flutter_ui_toolkit: ^0.0.3+9 copied to clipboard

Flutter UI Toolkit is a pre-built collection of the most used widgets to create apps. The idea is that you can use these widgets the way you use classes in HTML and CSS.

36
likes
120/ 140
pub points
48%
popularity

We analyzed this package 3 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

49 out of 161 API elements (30.4 %) have documentation comments.

Some symbols that are missing documentation: UIAction, UIAction.UIAction, UIAction.UIAction.UIAction, UIAction.UIAction.child, UIAction.UIAction.onPressed.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:flutter_ui_toolkit/flutter_ui_toolkit.dart that imports:
  • package:flutter_ui_toolkit/UIActionSheet/action_sheet_factory.dart that imports:
  • package:universal_io/io.dart that imports:
  • package:universal_io/src/_exports_in_browser.dart that imports:
  • package:universal_io/src/internet_address.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 46 issues. Showing the first 2:

WARNING: The '?' is unnecessary because 'dynamic' is nullable without it.

lib/UIUtils.dart:58:56

   ╷
58 │   static dynamic getStyle(UIDefaults? defaults, dynamic? defaultProp, dynamic? overrideWith, dynamic defaultTo) {
   │                                                        ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/UIUtils.dart

WARNING: The '?' is unnecessary because 'dynamic' is nullable without it.

lib/UIUtils.dart:58:78

   ╷
58 │   static dynamic getStyle(UIDefaults? defaults, dynamic? defaultProp, dynamic? overrideWith, dynamic defaultTo) {
   │                                                                              ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/UIUtils.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
universal_io ^2.0.4 2.2.2 2.2.2
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

36
likes
120
pub points
48%
popularity

Publisher

unverified uploader

Flutter UI Toolkit is a pre-built collection of the most used widgets to create apps. The idea is that you can use these widgets the way you use classes in HTML and CSS.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, universal_io

More

Packages that depend on flutter_ui_toolkit