flutter_scripts 0.0.3 copy "flutter_scripts: ^0.0.3" to clipboard
flutter_scripts: ^0.0.3 copied to clipboard

Run dart/flutter scripts defined in a pubspec.yaml

46
likes
110/ 140
pub points
73%
popularity

We analyzed this package 6 days ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1 out of 1 API elements (100.0 %) have documentation comments.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.3.1 2.4.2 2.4.2
cli_menu ^0.3.0-nullsafety.0 0.3.0-nullsafety.0 0.4.0+1
mason_logger ^0.1.0-dev.12 0.1.4 0.2.12
pub_updater ^0.2.1 0.2.4 0.4.0
yaml ^3.1.1 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
cli_util - 0.3.5 0.4.1
collection - 1.18.0 1.18.0
file - 6.1.4 7.0.0
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.0.2
json_annotation - 4.8.1 4.8.1
meta - 1.12.0 1.12.0
path - 1.9.0 1.9.0
platform - 3.1.4 3.1.4
process - 4.2.4 5.0.2
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.3.0-nullsafety.0` on cli_menu does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions cli_menu to update the constraint.

The constraint `^0.1.0-dev.12` on mason_logger does not support the stable version `0.2.0`.

Try running dart pub upgrade --major-versions mason_logger to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.