flutter_pseudolocalizor 0.3.0
flutter_pseudolocalizor: ^0.3.0

Dart native
Flutter Android iOS

A Pseudolocalization tool for Flutter and Dart which generates pseudo, nonsensical translations for multiple languages from a given English source.

2
likes
90 / 110
pub points
1 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 18 out of 20 API elements (90.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:flutter_pseudolocalizor/flutter_pseudolocalizor.dart that imports:
  • package:flutter_pseudolocalizor/src/services/pseudolocalizor.dart that imports:
  • package:flutter_pseudolocalizor/src/services/csv_generator.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

INFO: Use isNotEmpty instead of length

lib/src/utils/reg_exp_utils.dart:5:29

  ╷
5 │     if (patterns != null && patterns.length > 0) {
  │                             ^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/utils/reg_exp_utils.dart

INFO: Use isEmpty instead of length

lib/src/utils/utils.dart:20:30

   ╷
20 │     if (inputList == null || inputList.length == 0) {
   │                              ^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/utils/utils.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
meta^1.1.61.2.41.2.4
yaml^2.2.02.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
path-1.7.01.7.0
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

2
likes
90
pub points
1%
popularity

Publisher

defuncart.com

A Pseudolocalization tool for Flutter and Dart which generates pseudo, nonsensical translations for multiple languages from a given English source.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

meta, yaml

More

Packages that depend on flutter_pseudolocalizor