flutter_pos_printer 1.0.4
flutter_pos_printer: ^1.0.4 copied to clipboard

A library to discover printers, and send printer commands.

1
likes
70/ 130
pub points
56%
popularity

We analyzed this package 2 days ago, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/feedmepos/flutter_printer/packages/flutter_pos_printer was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 151 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:flutter_pos_printer/flutter_pos_printer.dart that declares support for platforms: Android, iOS, Windows.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/flutter_pos_printer.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
enum_to_string^2.0.12.0.12.0.1
esc_pos_utils_forked^1.0.31.0.31.0.3
flutterflutter0.0.00.0.0
flutter_star_prnt^2.3.62.3.62.3.6
image^3.0.83.1.03.1.0
network_info_plus^1.1.01.3.02.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.1.63.1.6
args-2.3.02.3.0
characters-1.1.01.2.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
dbus-0.5.60.6.6
ffi-1.1.21.1.2
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.7.01.7.0
network_info_plus_linux-1.1.01.1.0
network_info_plus_macos-1.3.01.3.0
network_info_plus_platform_interface-1.1.01.1.0
network_info_plus_web-1.0.11.0.1
network_info_plus_windows-1.0.21.0.2
nm-0.3.00.4.1
path-1.8.01.8.0
pedantic-1.11.11.11.1
petitparser-4.4.04.4.0
plugin_platform_interface-2.0.22.0.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.1.0` on network_info_plus does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions network_info_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.