flutter_paygateglobal 0.1.3 copy "flutter_paygateglobal: ^0.1.3" to clipboard
flutter_paygateglobal: ^0.1.3 copied to clipboard

Integrate easily the Paygate Global Platform into your Flutter app.

12
likes
140/ 160
pub points
64%
popularity

We analyzed this package 28 hours ago, and awarded it 140 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

23 out of 115 API elements (20.0 %) have documentation comments.

Some symbols that are missing documentation: account_balance, account_balance.AccountBalance, account_balance.AccountBalance.AccountBalance, account_balance.AccountBalance.byProvider, account_balance.AccountBalance.AccountBalance.fromJson.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_paygateglobal/flutter_paygateglobal.dart that imports:
  • package:flutter_paygateglobal/paygate/models/index.dart that imports:
  • package:flutter_paygateglobal/paygate/models/new_transaction_response.dart that imports:
  • package:flutter_paygateglobal/paygate/paygate.dart that imports:
  • package:flutter_paygateglobal/paygate/api/v2/new_transaction.dart that imports:
  • package:flutter_paygateglobal/paygate/utils/tab_launcher.dart that imports:
  • package:flutter_custom_tabs/flutter_custom_tabs.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:flutter_paygateglobal/flutter_paygateglobal.dart that imports:
  • package:flutter_paygateglobal/paygate/models/index.dart that imports:
  • package:flutter_paygateglobal/paygate/models/new_transaction_response.dart that imports:
  • package:flutter_paygateglobal/paygate/paygate.dart that imports:
  • package:flutter_paygateglobal/paygate/api/v2/new_transaction.dart that imports:
  • package:flutter_paygateglobal/paygate/utils/tab_launcher.dart that imports:
  • package:flutter_custom_tabs/flutter_custom_tabs.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:flutter_paygateglobal/flutter_paygateglobal.dart that imports:
  • package:flutter_paygateglobal/paygate/models/index.dart that imports:
  • package:flutter_paygateglobal/paygate/models/new_transaction_response.dart that imports:
  • package:flutter_paygateglobal/paygate/paygate.dart that imports:
  • package:flutter_paygateglobal/paygate/api/v2/new_transaction.dart that imports:
  • package:flutter_paygateglobal/paygate/utils/tab_launcher.dart that imports:
  • package:flutter_custom_tabs/flutter_custom_tabs.dart that declares support for platforms: Android, iOS, Web.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_custom_tabs ^1.0.4 1.2.1 2.0.0+1
http ^1.1.0 1.2.1 1.2.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
flutter_custom_tabs_platform_interface - 1.2.0 2.0.0
flutter_custom_tabs_web - 1.1.0 2.0.0
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.1.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.4` on flutter_custom_tabs does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions flutter_custom_tabs to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

12
likes
140
pub points
64%
popularity

Publisher

verified publishertheresilient.dev

Integrate easily the Paygate Global Platform into your Flutter app.

Homepage

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter, flutter_custom_tabs, http

More

Packages that depend on flutter_paygateglobal