flutter_mashov_api 0.0.5
flutter_mashov_api: ^0.0.5 copied to clipboard

Flutter Android iOS

The Mashov API - for Flutter. see https://github.com/yanir-edri/flutter-mashov-api for more.

0
likes
60 / 110
pub points
0 %
popularity

We analyzed this package on Jan 16, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/yanir-edri/flutter-mashov-api was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 41 out of 285 API elements (14.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flutter_mashov_api/flutter_mashov_api.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 44 issues. Showing the first 2:

INFO: 'getInjector' is deprecated and shouldn't be used. Prefer to use the factory constructor Injector([String name = "default"]).

lib/src/controller/api_controller.dart:33:34

   ╷
33 │     Injector injector = Injector.getInjector();
   │                                  ^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/controller/api_controller.dart

INFO: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

lib/src/controller/api_controller.dart:47:3

   ╷
47 │   Future<Result<List<School>>> getSchools() =>
   │   ^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/controller/api_controller.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutter_simple_dependency_injection^1.0.01.0.41.0.4
http^0.12.0+10.12.20.12.2
test^1.5.1+11.15.71.15.7
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.014.0.0
analyzer-0.41.20.41.2
args-1.6.01.6.0
async-2.4.22.4.2
boolean_selector-2.0.02.0.0
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.1.3
cli_util-0.2.00.2.0
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
coverage-0.14.20.15.0
crypto-2.1.52.1.5
file-5.2.15.2.1
glob-1.2.01.2.0
http_multi_server-2.2.02.2.0
http_parser-3.1.43.1.4
intl-0.16.10.16.1
io-0.3.40.3.4
js-0.6.20.6.2
logging-0.11.40.11.4
matcher-0.12.90.12.9
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
mime-0.9.70.9.7
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
node_preamble-1.4.121.4.12
package_config-1.9.31.9.3
path-1.7.01.7.0
pedantic-1.9.21.9.2
pool-1.4.01.4.0
pub_semver-1.4.41.4.4
shelf-0.7.90.7.9
shelf_packages_handler-2.0.02.0.0
shelf_static-0.2.9+10.2.9+1
shelf_web_socket-0.2.30.2.3
source_map_stack_trace-2.0.02.0.0
source_maps-0.10.90.10.9
source_span-1.7.01.7.0
stack_trace-1.9.61.9.6
stream_channel-2.0.02.0.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
test_api-0.2.18+10.2.18+1
test_core-0.3.11+40.3.11+4
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
vm_service-4.2.05.5.0
watcher-0.9.7+150.9.7+15
web_socket_channel-1.1.01.1.0
webkit_inspection_protocol-0.7.40.7.4
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
60
pub points
0%
popularity

The Mashov API - for Flutter. see https://github.com/yanir-edri/flutter-mashov-api for more.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

yanir.edri1@gmail.com

License

unknown (LICENSE)

Dependencies

flutter, flutter_simple_dependency_injection, http, test

More

Packages that depend on flutter_mashov_api