flutter_markdown_editor 2.0.0 copy "flutter_markdown_editor: ^2.0.0" to clipboard
flutter_markdown_editor: ^2.0.0 copied to clipboard

A package for markdown editor widget, you can use pre-exist editors or customize the view to build yours.

6
likes
120/ 140
pub points
47%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

26 out of 31 API elements (83.9 %) have documentation comments.

Some symbols that are missing documentation: editor_field, editor_icons, editor_icons.PromptFunction, editor_preview, flutter_markdown_editor.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_markdown_editor/flutter_markdown_editor.dart that imports:
  • package:flutter_markdown_editor/editor_preview.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:flutter_markdown_editor/flutter_markdown_editor.dart that imports:
  • package:flutter_markdown_editor/editor_preview.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:flutter_markdown_editor/flutter_markdown_editor.dart that imports:
  • package:flutter_markdown_editor/editor_preview.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: 'canLaunch' is deprecated and shouldn't be used. Use canLaunchUrl instead.

lib/editor_preview.dart:34:40

   ╷
34 │             if (href == null || !await canLaunch(href)) {
   │                                        ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/editor_preview.dart

INFO: 'launch' is deprecated and shouldn't be used. Use launchUrl instead.

lib/editor_preview.dart:45:15

   ╷
45 │               launch(href);
   │               ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/editor_preview.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_markdown ^0.6.8 0.6.9+1 0.7.1
fluttertoast ^8.0.8 8.2.5 8.2.5
markdown ^4.0.0 4.0.1 7.2.2
url_launcher ^6.0.12 6.2.6 6.2.6
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
characters - 1.3.0 1.3.0
charcode - 1.3.1 1.3.1
collection - 1.18.0 1.18.0
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
url_launcher_android - 6.3.2 6.3.2
url_launcher_ios - 6.3.0 6.3.0
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.8` on flutter_markdown does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions flutter_markdown to update the constraint.

The constraint `^4.0.0` on markdown does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions markdown to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

6
likes
120
pub points
47%
popularity

Publisher

unverified uploader

A package for markdown editor widget, you can use pre-exist editors or customize the view to build yours.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_markdown, fluttertoast, markdown, url_launcher

More

Packages that depend on flutter_markdown_editor