flutter_i18n_locize 0.0.3
flutter_i18n_locize: ^0.0.3 copied to clipboard

Flutter Android iOS Linux macOS Windows

Easy integration locize.io to flutter_i18n. Contains methods to fetch translations and upload new translations.

1
likes
90 / 110
pub points
23 %
popularity

We analyzed this package on Mar 7, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 22 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:flutter_i18n_locize/flutter_i18n_locize.dart that imports:
  • package:flutter_i18n_locize/config.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dio^3.0.03.0.103.0.10
flutterflutter0.0.00.0.0
yaml^2.2.12.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
http_parser-3.1.44.0.0
meta-1.3.01.3.0
path-1.8.01.8.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.2.1` on yaml does not support the stable version `3.0.0`, that was published 29 days ago.

When yaml is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions yaml to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.

1
likes
90
pub points
23%
popularity

Easy integration locize.io to flutter_i18n. Contains methods to fetch translations and upload new translations.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

matrenin44@gmail.com

License

MIT (LICENSE)

Dependencies

dio, flutter, yaml

More

Packages that depend on flutter_i18n_locize