flutter_html_view 0.5.12
flutter_html_view: ^0.5.12 copied to clipboard

Flutter Plugin to render html, Flutter has no default support to render html so this package helps you to render your html to native widgets

21
likes
70/ 130
pub points
88%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 73 API elements (13.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:flutter_html_view/flutter_html_view.dart that imports:
  • package:flutter_custom_tabs/flutter_custom_tabs.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/flutter_html_text.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/html_parser.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^0.7.00.7.03.1.0
flutterflutter0.0.00.0.0
flutter_custom_tabs^0.6.00.6.01.0.3
flutter_markdown^0.2.00.2.00.6.6
html^0.13.3+30.13.4+20.15.0
html2md^0.3.00.3.11.2.5
video_player0.10.0+20.10.0+22.2.3
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.02.3.0
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
csslib-0.15.00.17.0
flutter_cache_manager-0.3.23.1.2
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.3
http_parser-3.1.44.0.0
js-0.6.30.6.3
markdown-2.1.84.0.0
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider-0.5.0+12.0.4
pedantic-1.11.11.11.1
plugin_platform_interface-1.0.32.0.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-1.3.2+42.0.0+4
sqflite_common-1.0.3+32.0.1+1
string_scanner-1.1.01.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher-5.7.106.0.10
url_launcher_linux-0.0.1+42.0.2
url_launcher_macos-0.0.1+92.0.2
url_launcher_platform_interface-1.0.92.0.4
url_launcher_web-0.1.5+32.0.4
url_launcher_windows-0.0.1+32.0.2
utf-0.9.0+50.9.0+5
uuid-2.2.23.0.4
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^0.7.0` on cached_network_image does not support the stable version `0.8.0`.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

The constraint `^0.6.0` on flutter_custom_tabs does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions flutter_custom_tabs to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0-dev.28.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.1+1, Flutter 2.5.0, Dart 2.14.0.

21
likes
70
pub points
88%
popularity

Publisher

karthikponnam.dev

Flutter Plugin to render html, Flutter has no default support to render html so this package helps you to render your html to native widgets

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

cached_network_image, flutter, flutter_custom_tabs, flutter_markdown, html, html2md, video_player

More

Packages that depend on flutter_html_view