flutter_graphql_client 0.1.23
flutter_graphql_client: ^0.1.23 copied to clipboard

Client to POST to GraphQL server

6
likes
110/ 130
pub points
79%
popularity

We analyzed this package on Sep 22, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 16 out of 61 API elements (26.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:flutter_graphql_client/graph_event_bus.dart that imports:
  • package:flutter_graphql_client/src/i_event_bus_database_helper.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
gql^0.13.00.13.00.13.0
http^0.13.30.13.30.13.3
meta^1.3.01.7.01.7.0
path^1.8.01.8.01.8.0
path_provider^2.0.22.0.52.0.5
source_span^1.8.01.8.11.8.1
sqflite^2.0.0+32.0.0+42.0.0+4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
ffi-1.1.21.1.2
file-6.1.26.1.2
http_parser-4.0.04.0.0
path_provider_linux-2.1.02.1.0
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.32.0.3
pedantic-1.11.11.11.1
platform-3.0.23.0.2
plugin_platform_interface-2.0.12.0.1
process-4.2.34.2.3
sky_engine-0.0.990.0.99
sqflite_common-2.0.1+12.0.1+1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.2.92.2.9
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.1+1, Flutter 2.5.0, Dart 2.14.0.