flutter_google_places_sdk 0.3.7 copy "flutter_google_places_sdk: ^0.3.7" to clipboard
flutter_google_places_sdk: ^0.3.7 copied to clipboard

A Flutter plugin for google places sdk that uses the native libraries on each platform

70
likes
130/ 140
pub points
96%
popularity

We analyzed this package 35 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

96 out of 171 API elements (56.1 %) have documentation comments.

Some symbols that are missing documentation: flutter_google_places_sdk, flutter_google_places_sdk.AddressComponent.copyWith, flutter_google_places_sdk.AddressComponent.toJson, flutter_google_places_sdk.AutocompletePrediction.copyWith, flutter_google_places_sdk.AutocompletePrediction.toJson.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/flutter_google_places_sdk.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_google_places_sdk_android ^0.1.8 0.1.8 0.1.8
flutter_google_places_sdk_ios ^0.1.3 0.1.3 0.1.3
flutter_google_places_sdk_linux ^0.1.4 0.1.4 0.1.4
flutter_google_places_sdk_macos ^0.1.4 0.1.4 0.1.4
flutter_google_places_sdk_platform_interface ^0.2.7 0.2.7 0.2.7
flutter_google_places_sdk_web ^0.1.6 0.1.6 0.1.6
flutter_google_places_sdk_windows ^0.1.4 0.1.4 0.1.4
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
flutter_google_places_sdk_http - 0.1.4 0.1.4
flutter_web_plugins - 0.0.0 0.0.0
freezed_annotation - 2.4.1 2.4.1
google_maps - 6.3.0 7.1.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
intl - 0.19.0 0.19.0
js - 0.6.7 0.7.1
js_wrapping - 0.7.4 0.7.4
json_annotation - 4.8.1 4.8.1
latlong2 - 0.9.0 0.9.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.0 0.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Flutter 3.19.0, Dart 3.3.0.

Check the analysis log for details.