flutter_google_map_location_picker 5.6.2
flutter_google_map_location_picker: ^5.6.2 copied to clipboard

Flutter Android

🌍 Map location picker for flutter Based on google_maps_flutter

0
likes
65 / 110
pub points
44 %
popularity

We analyzed this package on Mar 2, 2021, and awarded it 65 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 1 link is insecure.

CHANGELOG.md:48:61

   ╷
48 │ <li>Prepare for 1.0.0 version of sensors and package_info. (<a href="http://github.com/amirh/dart_lsc">dart_lsc</a>)</li>
   │                                                             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 57 out of 147 API elements (38.8 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform iOS

Because:

  • package:flutter_google_map_location_picker/generated/intl/messages_all.dart that declares support for platforms: Android
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 20 issues. Showing the first 2:

INFO: Unused import: 'dart:math'.

lib/src/google_map_location_picker.dart:3:8

  ╷
3 │ import 'dart:math';
  │        ^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/google_map_location_picker.dart

INFO: Unused import: 'utils/location_utils.dart'.

lib/src/map.dart:19:8

   ╷
19 │ import 'utils/location_utils.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/map.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
android_intent^0.3.7+30.3.7+72.0.0
flutterflutter0.0.00.0.0
flutter_localizationsflutter0.0.00.0.0
geolocator^6.0.0+46.2.17.0.1
google_maps_flutter^0.5.320.5.332.0.0
http^0.12.20.12.20.13.0
intl>=0.16.0 <=0.16.10.16.10.17.0
intl_translation>=0.17.9 <=0.17.100.17.100.17.10+1
package_info>=0.4.0+14 <2.0.00.4.3+42.0.0
provider^4.3.2+24.3.34.3.3
stack_trace^1.9.51.9.61.10.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.017.0.0
analyzer-0.39.171.1.0
args-1.6.02.0.0
async-2.4.22.5.0
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
cli_util-0.2.00.3.0
collection-1.15.0-nullsafety.31.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
csslib-0.16.20.17.0
dart_style-1.3.61.3.14
file-5.2.16.1.0
flutter_plugin_android_lifecycle-1.0.112.0.0
flutter_web_plugins-0.0.00.0.0
geolocator_platform_interface-1.0.92.0.0
geolocator_web-1.0.12.0.1
glob-1.2.02.0.0
google_maps_flutter_platform_interface-1.2.02.0.0
html-0.14.0+40.15.0
http_parser-3.1.44.0.0
js-0.6.20.6.3
meta-1.3.0-nullsafety.31.3.0
nested-0.0.41.0.0
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
path-1.8.0-nullsafety.11.8.0
pedantic-1.9.21.10.0
petitparser-3.1.04.0.2
platform-2.2.13.0.0
plugin_platform_interface-1.0.32.0.0
pub_semver-1.4.42.0.0
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
stream_transform-1.2.02.0.0
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^0.3.7+3` on android_intent does not support the stable version `2.0.0`, that was published 6 days ago.

When android_intent is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions android_intent to update the constraint.

The constraint `^6.0.0+4` on geolocator does not support the stable version `7.0.0`, that was published 8 days ago.

When geolocator is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions geolocator to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.