flutter_flicker 0.75.0 icon indicating copy to clipboard operation
flutter_flicker: ^0.75.0 copied to clipboard

App state, routing and other shared patterns for Code Collective flutter projects

3
likes
80/ 120
pub points
35%
popularity

We analyzed this package 8 days ago, and awarded it 80 pub points (of a possible 120):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 10icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: The import of 'package:flutter_flicker/navigation/menu_configuration.dart' is unnecessary because all of the used elements are also provided by the import of '../flutter_flicker.dart'.

lib/configuration/configuration.dart:4:8

  ╷
4 │ import 'package:flutter_flicker/navigation/menu_configuration.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/configuration/configuration.dart

INFO: The import of 'package:flutter_flicker/navigation/route_configuration.dart' is unnecessary because all of the used elements are also provided by the import of '../flutter_flicker.dart'.

lib/configuration/configuration.dart:5:8

  ╷
5 │ import 'package:flutter_flicker/navigation/route_configuration.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/configuration/configuration.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_riverpod^0.14.00.14.0+31.0.3
google_fonts>=1.0.0 <3.0.02.3.22.3.2
intl>=0.16.0 <1.0.00.17.00.17.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.9.02.9.0
characters-1.2.01.2.1
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.16.0
crypto-3.0.23.0.2
ffi-1.1.21.1.2
file-6.1.26.1.2
freezed_annotation-0.14.32.0.3
http-0.13.40.13.4
http_parser-4.0.04.0.0
json_annotation-4.5.04.5.0
material_color_utilities-0.1.30.1.5
meta-1.7.01.7.0
path-1.8.11.8.1
path_provider-2.0.92.0.9
path_provider_android-2.0.132.0.13
path_provider_ios-2.0.82.0.8
path_provider_linux-2.1.52.1.5
path_provider_macos-2.0.52.0.5
path_provider_platform_interface-2.0.32.0.3
path_provider_windows-2.0.52.0.5
platform-3.1.03.1.0
plugin_platform_interface-2.1.22.1.2
process-4.2.44.2.4
riverpod-0.14.0+31.0.3
sky_engine-0.0.990.0.99
source_span-1.9.01.9.0
state_notifier-0.7.2+10.7.2+1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.12.1.2
win32-2.5.22.5.2
xdg_directories-0.2.0+10.2.0+1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.14.0` on flutter_riverpod does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions flutter_riverpod to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.12, Flutter 2.10.5, Dart 2.16.2.

3
likes
80
pub points
35%
popularity

Publisher

verified publisher iconcodecollective.com

App state, routing and other shared patterns for Code Collective flutter projects

Homepage (insecure)

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, flutter_riverpod, google_fonts, intl

More

Packages that depend on flutter_flicker