flutter_calendar 0.0.9 copy "flutter_calendar: ^0.0.9" to clipboard
flutter_calendar: ^0.0.9 copied to clipboard

A calendar widget that uses Material Design.

7
likes
10/ 160
pub points
76%
popularity

We analyzed this package 3 days ago, and awarded it 10 pub points (of a possible 160):

failed
Follow Dart file conventions
0 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 3 image links are insecure.

README.md:12:4

   ╷
12 │ <p><img src="http://res.cloudinary.com/ericwindmill/image/upload/c_scale,h_500/v1518649521/flutter_calendar_standard_lu6l9i.gif" alt="standard view" /></p>
   │    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. Check out the Dart conventions for Maintaining a package changelog.

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

These platforms are not supported:

Tag detection failed.

Exception: Couldn't read pubspec.yaml in /Users/matthew/Library/Flutter/.pub-cache/hosted/pub.dartlang.org/date_utils-0.1.0+3. PathNotFoundException: Cannot open file, path = '/Users/matthew/Library/Flutter/.pub-cache/hosted/pub.dartlang.org/date_utils-0.1.0+3/pubspec.yaml' (OS Error: No such file or directory, errno = 2)

Tag detection failed.

Exception: Couldn't read pubspec.yaml in /Users/matthew/Library/Flutter/.pub-cache/hosted/pub.dartlang.org/date_utils-0.1.0+3. PathNotFoundException: Cannot open file, path = '/Users/matthew/Library/Flutter/.pub-cache/hosted/pub.dartlang.org/date_utils-0.1.0+3/pubspec.yaml' (OS Error: No such file or directory, errno = 2)

Tag detection failed.

Exception: Couldn't read pubspec.yaml in /Users/matthew/Library/Flutter/.pub-cache/hosted/pub.dartlang.org/date_utils-0.1.0+3. PathNotFoundException: Cannot open file, path = '/Users/matthew/Library/Flutter/.pub-cache/hosted/pub.dartlang.org/date_utils-0.1.0+3/pubspec.yaml' (OS Error: No such file or directory, errno = 2)

Tag detection failed.

Exception: Couldn't read pubspec.yaml in /Users/matthew/Library/Flutter/.pub-cache/hosted/pub.dartlang.org/date_utils-0.1.0+3. PathNotFoundException: Cannot open file, path = '/Users/matthew/Library/Flutter/.pub-cache/hosted/pub.dartlang.org/date_utils-0.1.0+3/pubspec.yaml' (OS Error: No such file or directory, errno = 2)

Tag detection failed.

Exception: Couldn't read pubspec.yaml in /Users/matthew/Library/Flutter/.pub-cache/hosted/pub.dartlang.org/date_utils-0.1.0+3. PathNotFoundException: Cannot open file, path = '/Users/matthew/Library/Flutter/.pub-cache/hosted/pub.dartlang.org/date_utils-0.1.0+3/pubspec.yaml' (OS Error: No such file or directory, errno = 2)

Tag detection failed.

Exception: Couldn't read pubspec.yaml in /Users/matthew/Library/Flutter/.pub-cache/hosted/pub.dartlang.org/date_utils-0.1.0+3. PathNotFoundException: Cannot open file, path = '/Users/matthew/Library/Flutter/.pub-cache/hosted/pub.dartlang.org/date_utils-0.1.0+3/pubspec.yaml' (OS Error: No such file or directory, errno = 2)

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running flutter pub outdated failed with the following output:
The lower bound of "sdk: '>=2.0.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.4.4. Cannot run `flutter pub outdated`.

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=2.0.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.4.4.

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=2.0.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (3.4.3)

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=2.0.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

0/20 points: Compatible with dependency constraint lower bounds

flutter pub downgrade failed with:

OUT:
Resolving dependencies...
ERR:
The lower bound of "sdk: '>=2.0.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.

The current Dart SDK (3.4.3) only supports null safety.

For details, see https://dart.dev/null-safety

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

7
likes
10
pub points
76%
popularity

Publisher

unverified uploader

A calendar widget that uses Material Design.

Repository (GitHub)
View/report issues

License

unknown (license)

Dependencies

date_utils, flutter, intl, tuple

More

Packages that depend on flutter_calendar