flutter_alibc_extend 0.0.9
flutter_alibc_extend: ^0.0.9 copied to clipboard

flutter_alibc,flutter版本的阿里百川,V4.0.2。更新日期:2019-9-18

0
likes
30 / 110
pub points
0 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 30 pub points (of a possible 110):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

The package description contains too many non-ASCII characters.

The site uses English as its primary language. The content of the description field in your package's pubspec.yaml should primarily contain characters used in English.

0/5 points: Provide a valid README.md

README.md is empty.

The README.md file should inform others about your project, what it does, and how they can use it. See: the example generated by stagehand.

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 12 out of 94 API elements (12.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Tag detection failed.

Exception: Could not find package dir of flutter_alibc

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 92 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:flutter_alibc/albc_tools.dart'.

lib/flutter_alibc.dart:5:8

  ╷
5 │ import 'package:flutter_alibc/albc_tools.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_alibc.dart

ERROR: Target of URI doesn't exist: 'package:flutter_alibc/alibc_const_key.dart'.

lib/flutter_alibc.dart:6:8

  ╷
6 │ import 'package:flutter_alibc/alibc_const_key.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/flutter_alibc.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

0
likes
30
pub points
0%
popularity

flutter_alibc,flutter版本的阿里百川,V4.0.2。更新日期:2019-9-18

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

13402634208@163.com

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_alibc_extend