flutter_alibc_extend 0.0.9

example/README.md

flutter_alibc_example #

Demonstrates how to use the flutter_alibc plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_alibc_extend: ^0.0.9

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_alibc_extend/albc_tools.dart';
import 'package:flutter_alibc_extend/alibc_const_key.dart';
import 'package:flutter_alibc_extend/alibc_model.dart';
import 'package:flutter_alibc_extend/flutter_alibc.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
8
Learn more about scoring.

We analyzed this package on Feb 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Health issues and suggestions

Fix lib/flutter_alibc.dart. (-100 points)

Analysis of lib/flutter_alibc.dart failed with 89 errors, including:

line 5 col 8: Target of URI doesn't exist: 'package:flutter_alibc/albc_tools.dart'.

line 6 col 8: Target of URI doesn't exist: 'package:flutter_alibc/alibc_const_key.dart'.

line 7 col 8: Target of URI doesn't exist: 'package:flutter_alibc/alibc_model.dart'.

line 37 col 17: The name 'InitModel' isn't a type so it can't be used as a type argument.

line 40 col 12: The method 'InitModel' isn't defined for the class 'FlutterAlibc'.

Fix lib/alibc_const_key.dart. (-1.49 points)

Analysis of lib/alibc_const_key.dart reported 3 hints:

line 8 col 8: Unused import: 'package:flutter/foundation.dart'.

line 20 col 17: Name non-constant identifiers using lowerCamelCase.

line 21 col 17: Name non-constant identifiers using lowerCamelCase.

Format lib/albc_tools.dart.

Run flutter format to format lib/albc_tools.dart.

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-10 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test