flute 1.0.6 icon indicating copy to clipboard operation
flute: ^1.0.6 copied to clipboard

A weird flutter package that has some extensions and local storage.

0
likes
120/ 140
pub points
32%
popularity

We analyzed this package in the last hour, and awarded it 120 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 57 out of 88 API elements (64.8 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: The import of 'language_base.dart' is unnecessary because all of the used elements are also provided by the import of '../../../flute.dart'.

lib/src/flute_providers/localization/localization_provider.dart:4:8

  ╷
4 │ import 'language_base.dart';
  │        ^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/flute_providers/localization/localization_provider.dart

lib/src/flute_provider/documentation.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dio^4.0.04.0.64.0.6
flutterflutter0.0.00.0.0
path_provider^2.0.52.0.122.0.12
provider^6.0.16.0.56.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.17.01.17.1
ffi-2.0.12.0.1
file-6.1.46.1.4
http_parser-4.0.24.0.2
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
nested-1.0.01.0.0
path-1.8.31.8.3
path_provider_android-2.0.222.0.22
path_provider_foundation-2.1.12.1.1
path_provider_linux-2.1.72.1.7
path_provider_platform_interface-2.0.52.0.5
path_provider_windows-2.1.32.1.3
platform-3.1.03.1.0
plugin_platform_interface-2.1.32.1.3
process-4.2.44.2.4
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.42.1.4
win32-3.1.34.1.1
xdg_directories-0.2.0+30.2.0+3

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

0
likes
120
pub points
32%
popularity

Publisher

unverified uploader

A weird flutter package that has some extensions and local storage.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

dio, flutter, path_provider, provider

More

Packages that depend on flute