fluig_oauth1 1.0.1

Dart native js
Flutter Android iOS web

A starting point for Dart libraries or applications.

0
likes
80 / 110
pub points
0 %
popularity

We analyzed this package on Sep 22, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 27 out of 47 API elements (57.4 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: Unused import: 'authorization_header_builder.dart'.

lib/src/fluig_connect.dart:15:8

   ╷
15 │ import 'authorization_header_builder.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/fluig_connect.dart

INFO: The value of the field '_credentials' isn't used.

lib/src/fluig_connect.dart:21:21

   ╷
21 │   final Credentials _credentials;
   │                     ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/fluig_connect.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crypto^2.0.02.1.52.1.5
http>=0.11.0 <0.13.00.12.20.12.2
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
http_parser-3.1.43.1.4
meta-1.2.31.2.3
path-1.7.01.7.0
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
80
pub points
0%
popularity

A starting point for Dart libraries or applications.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

aldoiguerra@gmail.com

License

BSD (LICENSE)

Dependencies

crypto, http

More

Packages that depend on fluig_oauth1