fluig_oauth1 1.0.1

  • Readme
  • Changelog
  • Installing
  • new57

OAuth1 Fluig Totvs #

This lib is provide by using core of https://pub.dev/packages/oauth1. Thanks.

Usage #

Add to pubspec.yaml:

dependencies:
  fluig_oauth1: ^1.0.0

Please use like below.

import 'package:fluig_oauth1/fluig_oauth1.dart';

void main() {

  String url = "<url_fluig>";

  const String apiKey = '<client_token>';
  const String apiSecret = '<client_token_secret>';
  var clientCredentials = ClientCredentials(apiKey, apiSecret);

  var user = User("<user>","<pass>");

  var fluigConnect = FluigConnect(url,clientCredentials,user);

  fluigConnect.connect().then((client) => {

    client. get (url + 'api/public/2.0/users/getCurrent').then((res) {

      print(res.body);

    })

  }).catchError((err) {

    print("mostrando erro: "+err.toString());

  });

}


0.0.0 #

  • Initial version, created by Aldo Ianelo Guerra

1.0.0 #

  • Versão de publicação

1.0.1 #

  • Change docs

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fluig_oauth1: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fluig_oauth1/fluig_oauth1.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
19
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
92
Overall:
Weighted score of the above. [more]
57
Learn more about scoring.

We analyzed this package on Jan 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4

Health suggestions

Fix lib/src/fluig_connect.dart. (-2.48 points)

Analysis of lib/src/fluig_connect.dart reported 5 hints:

line 15 col 8: Unused import: 'authorization_header_builder.dart'.

line 21 col 21: The value of the field '_credentials' isn't used.

line 47 col 27: Don't explicitly initialize variables to null.

line 51 col 15: The value of the local variable 'code' isn't used.

line 66 col 11: The value of the local variable 'encoding' isn't used.

Maintenance suggestions

The package description is too short. (-8 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and fluig_oauth1.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
crypto ^2.0.0 2.1.4
http >=0.11.0 <0.13.0 0.12.0+4
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.12
convert 2.1.1
http_parser 3.1.3
meta 1.1.8
path 1.6.4
source_span 1.6.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
pedantic ^1.8.0 1.9.0
test ^1.6.0