floater 0.0.5+1
floater: ^0.0.5+1 copied to clipboard

Flutter Android iOS

A framework that floats over flutter as a higher level construct to provide architecture and structure for complex flutter apps.

1
likes
70 / 110
pub points
32 %
popularity

We analyzed this package on Jan 25, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 178 API elements (7.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:floater/floater.dart that imports:
  • package:floater/src/widgets.dart that imports:
  • package:floater/src/navigation.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

lib/src/defensive.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/extensions.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutter_secure_storage^3.3.53.3.53.3.5
get_it^4.0.24.0.45.0.6
meta^1.1.81.3.0-nullsafety.61.3.0-nullsafety.6
pedantic^1.9.01.9.21.9.2
rxdart^0.24.10.24.10.25.0
shared_preferences>=0.5.12+4 <2.0.00.5.12+40.5.12+4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.5.0-nullsafety.3
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
ffi-0.1.30.1.3
file-5.2.15.2.1
intl-0.16.10.16.1
js-0.6.3-nullsafety.30.6.3-nullsafety.3
path-1.7.01.8.0-nullsafety.3
path_provider_linux-0.0.1+20.0.1+2
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
shared_preferences_linux-0.0.2+40.0.2+4
shared_preferences_macos-0.0.1+110.0.1+11
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.2+20.0.2+2
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.2` on get_it does not support the latest published version `5.0.6`

pubspec.yaml:14:11

   ╷
14 │   get_it: ^4.0.2
   │           ^^^^^^
   ╵
The constraint `^0.24.1` on rxdart does not support the latest published version `0.25.0`

pubspec.yaml:16:11

   ╷
16 │   rxdart: ^0.24.1
   │           ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
70
pub points
32%
popularity

A framework that floats over flutter as a higher level construct to provide architecture and structure for complex flutter apps.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

shreymahendru@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, flutter_secure_storage, get_it, meta, pedantic, rxdart, shared_preferences

More

Packages that depend on floater