flim 1.0.0 icon indicating copy to clipboard operation
flim: ^1.0.0 copied to clipboard

minimal data-driven sprite render and animation lib for Flutter

5
likes
100/ 130
pub points
31%
popularity

We analyzed this package 11 hours ago, and awarded it 100 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 43 out of 137 API elements (31.4 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
10 / 30icon to trigger folding of the section

10/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

WARNING: The '!' will have no effect because the receiver can't be null.

lib/src/game_render_box.dart:33:28

   ╷
33 │     WidgetsBinding.instance!.addObserver(this);
   │                            ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/game_render_box.dart

WARNING: The '!' will have no effect because the receiver can't be null.

lib/src/game_render_box.dart:40:28

   ╷
40 │     WidgetsBinding.instance!.removeObserver(this);
   │                            ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/game_render_box.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
asset_cache^1.0.01.0.12.0.0
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.1
collection-1.16.01.16.0
material_color_utilities-0.1.40.2.0
meta-1.7.01.8.0
path-1.8.21.8.2
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on asset_cache does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions asset_cache to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.14, Flutter 3.0.4, Dart 2.17.5.

5
likes
100
pub points
31%
popularity

Publisher

verified publisher iconapptakk.com

minimal data-driven sprite render and animation lib for Flutter

Homepage

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

asset_cache, flutter

More

Packages that depend on flim