flavor_config 1.2.0
flavor_config: ^1.2.0 copied to clipboard

Flutter Android iOS

An easy to use package for creating flavors for any environment.

1
likes
100 / 110
pub points
45 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 18 out of 33 API elements (54.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:flavor_config/flavor_config.dart that imports:
  • package:flavor_config/src/utils/device_utils.dart that imports:
  • package:device_info/device_info.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
device_info>=0.4.2+7 <2.0.01.0.02.0.0
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
device_info_platform_interface-1.0.12.0.1
meta-1.3.01.3.0
plugin_platform_interface-1.0.32.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.4.2+7 <2.0.0` on device_info does not support the stable version `2.0.0`, that was published 6 days ago.

When device_info is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions device_info to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.

1
likes
100
pub points
45%
popularity

Publisher

zino-hofmann.com

An easy to use package for creating flavors for any environment.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

device_info, flutter

More

Packages that depend on flavor_config