flame 0.29.3 icon indicating copy to clipboard operation
flame: ^0.29.3 copied to clipboard

A minimalist Flutter game engine, provides a nice set of somewhat independent modules you can choose from.

1015
likes
90/ 130
pub points
97%
popularity

We analyzed this package 18 days ago, and awarded it 90 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 381 out of 1277 API elements (29.8 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ MacOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flame/flame.dart that imports:
  • package:flame/flame_audio.dart that imports:
  • package:audioplayers/audioplayers.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:flame/flame.dart that imports:
  • package:flame/flame_audio.dart that imports:
  • package:audioplayers/audioplayers.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Web`.

Because:

  • package:flame/flame.dart that imports:
  • package:flame/flame_audio.dart that imports:
  • package:audioplayers/audio_cache.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:flame/flame.dart that imports:
  • package:flame/flame_audio.dart that imports:
  • package:audioplayers/audio_cache.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:flame/flame.dart that imports:
  • package:flame/flame_audio.dart that imports:
  • package:audioplayers/audio_cache.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:flame/flame.dart that imports:
  • package:flame/flame_audio.dart that imports:
  • package:audioplayers/audio_cache.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

INFO: The import of 'package:flutter/widgets.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/components/joystick/joystick_action.dart:8:8

  ╷
8 │ import 'package:flutter/widgets.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/components/joystick/joystick_action.dart

INFO: The import of 'dart:ui' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/painting.dart'.

lib/components/text_component.dart:1:8

  ╷
1 │ import 'dart:ui';
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/components/text_component.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
The current Dart SDK version is 2.17.3.

Because test >=1.15.5 <1.16.0-nullsafety depends on test_api 0.2.18+1 and test >=1.15.3 <1.15.5 depends on test_api 0.2.18, test >=1.15.3 <1.16.0-nullsafety requires test_api 0.2.18 or 0.2.18+1.
And because test >=1.15.0 <1.15.3 depends on test_api 0.2.17, test >=1.15.0 <1.16.0-nullsafety requires test_api 0.2.17 or 0.2.18 or 0.2.18+1.
And because test >=1.14.5 <1.15.0 depends on test_api 0.2.16 and test >=1.13.0 <1.14.5 depends on test_api 0.2.15, test >=1.13.0 <1.16.0-nullsafety requires test_api 0.2.15 or 0.2.16 or 0.2.17 or[...]
And because test >=1.12.0 <1.13.0 depends on test_api 0.2.14 and test >=1.3.0 <1.12.0 depends on boolean_selector ^1.0.0, test >=1.3.0 <1.16.0-nullsafety requires test_api 0.2.14 or 0.2.15 or 0.2[...]
And because test >=1.16.0-nullsafety.18 <1.16.0-nullsafety.19 depends on test_api 0.2.19-nullsafety.7 and test >=1.16.0-nullsafety.8 <1.16.0-nullsafety.18 depends on stream_channel >=2.1.0-nullsa[...]
And because test >=1.16.0-nullsafety <1.16.0-nullsafety.8 requires SDK version >=2.10.0-0 <2.12.0 and test >=1.16.0-nullsafety.19 <1.16.6 depends on test_api 0.2.19, test >=1.3.0 <1.16.6 requires[...]
And because every version of flutter_test from sdk depends on both boolean_selector 2.1.0 and stream_channel 2.1.0, if test >=1.3.0 <1.16.6 and flutter_test from sdk then test_api 0.2.14 or 0.2.1[...]
And because every version of flutter_test from sdk depends on test_api 0.4.9 and test >=1.16.6 depends on shelf_static ^1.0.0, if flutter_test from sdk and test >=1.3.0 then shelf_static ^1.0.0.
[2 more lines]

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.3.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.12, Flutter 3.0.1, Dart 2.17.1.

1015
likes
90
pub points
97%
popularity

Publisher

verified publisher iconflame-engine.org

A minimalist Flutter game engine, provides a nice set of somewhat independent modules you can choose from.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

audioplayers, box2d_flame, convert, flare_flutter, flutter, meta, ordered_set, synchronized

More

Packages that depend on flame