flagsmith_core 2.1.0+1 copy "flagsmith_core: ^2.1.0+1" to clipboard
flagsmith_core: ^2.1.0+1 copied to clipboard

Core Package of Flutter Client SDK for https://www.flagsmith.com/, Flagsmith is 100% Open Source. Host yourself or let us take care of the hosting.

1
likes
110/ 160
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 110 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: flagsmith_core,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: flagsmith_core.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

13 out of 107 API elements (12.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: flagsmith_core, flagsmith_core.CoreStorage.clear, flagsmith_core.CoreStorage.create, flagsmith_core.CoreStorage.delete, flagsmith_core.CoreStorage.getAll.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.19.0 1.19.0
crypto ^3.0.1 3.0.3 3.0.3
encrypt ^5.0.1 5.0.3 5.0.3
json_annotation ^4.0.1 4.9.0 4.9.0
rxdart >=0.26.0 <=0.27.2 0.27.2 0.28.0
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
asn1lib - 1.5.3 1.5.3
clock - 1.1.1 1.1.1
convert - 3.1.1 3.1.1
js - 0.7.1 0.7.1
meta - 1.15.0 1.15.0
pointycastle - 3.9.1 3.9.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.26.0 <=0.27.2` on rxdart does not support the stable version `0.27.3`.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 1 error:

  • UNCHECKED_USE_OF_NULLABLE_VALUE - lib/src/storage_provider.dart:141:68 - The property 'enabled' can't be unconditionally accessed because the receiver can be 'null'.

Run dart pub downgrade and then dart analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

1
likes
110
pub points
0%
popularity

Publisher

unverified uploader

Core Package of Flutter Client SDK for https://www.flagsmith.com/, Flagsmith is 100% Open Source. Host yourself or let us take care of the hosting.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, crypto, encrypt, json_annotation, rxdart

More

Packages that depend on flagsmith_core