firestore_helper 0.2.0+3
firestore_helper: ^0.2.0+3 copied to clipboard

Helper package for handling Firestore easier. It removes boilerplate code by abstracting most frequently used Firebase Firestore APIs.

1
likes
120/ 130
pub points
44%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 15 API elements (73.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 3 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:firestore_helper/firestore_helper.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, macOS, Web.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/firestore_helper.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/utils/mocked_classes.mocks.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
clock^1.1.01.1.01.1.0
cloud_firestore^2.5.12.5.42.5.4
cloud_firestore_platform_interface^5.4.15.4.35.4.3
firebase_core^1.6.01.8.01.8.0
flutterflutter0.0.00.0.0
logger^1.1.01.1.01.1.0
mockito^5.0.155.0.165.0.16
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-29.0.029.0.0
analyzer-2.6.02.6.0
args-2.3.02.3.0
async-2.8.22.8.2
boolean_selector-2.1.02.1.0
build-2.1.12.1.1
built_collection-5.1.15.1.1
built_value-8.1.28.1.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
cloud_firestore_web-2.4.42.4.4
code_builder-4.1.04.1.0
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
dart_style-2.2.02.2.0
file-6.1.26.1.2
firebase_core_platform_interface-4.0.14.0.1
firebase_core_web-1.1.01.1.0
fixnum-1.0.01.0.0
flutter_web_plugins-0.0.00.0.0
glob-2.0.22.0.2
js-0.6.30.6.3
logging-1.0.21.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
package_config-2.0.22.0.2
path-1.8.01.8.0
plugin_platform_interface-2.0.22.0.2
pub_semver-2.1.02.1.0
sky_engine-0.0.990.0.99
source_gen-1.1.11.1.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
test_api-0.4.60.4.6
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
watcher-1.0.11.0.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

1
likes
120
pub points
44%
popularity

Publisher

deimantas.dev

Helper package for handling Firestore easier. It removes boilerplate code by abstracting most frequently used Firebase Firestore APIs.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

clock, cloud_firestore, cloud_firestore_platform_interface, firebase_core, flutter, logger, mockito

More

Packages that depend on firestore_helper