fireproof_closet 0.91.3 copy "fireproof_closet: ^0.91.3" to clipboard
fireproof_closet: ^0.91.3 copied to clipboard

Cache your Firebase Storage images to the Fireproof Closet for blazingly fast access.

1
likes
120/ 140
pub points
10%
popularity

We analyzed this package 32 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

33 out of 36 API elements (91.7 %) have documentation comments.

Some symbols that are missing documentation: fireproof_closet, fireproof_closet.CachedDataAdapter, fireproof_closet.CachedDataAdapter.CachedDataAdapter.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ macOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:fireproof_closet/fireproof_closet.dart that imports:
  • package:fireproof_closet/src/fireproof_image_provider.dart that imports:
  • package:fireproof_closet/src/cached_data.dart that imports:
  • package:firebase_storage/firebase_storage.dart that declares support for platforms: Android, iOS, Windows, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:fireproof_closet/fireproof_closet.dart that imports:
  • package:fireproof_closet/src/fireproof_image_provider.dart that imports:
  • package:fireproof_closet/src/cached_data.dart that imports:
  • package:firebase_storage/firebase_storage.dart that imports:
  • package:firebase_storage_platform_interface/firebase_storage_platform_interface.dart that imports:
  • package:firebase_storage_platform_interface/src/platform_interface/platform_interface_reference.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: 'DecoderBufferCallback' is deprecated and shouldn't be used. Use ImageDecoderCallback with ImageProvider.loadImage instead. This feature was deprecated after v3.7.0-1.4.pre.

lib/src/fireproof_image_provider.dart:59:55

   ╷
59 │   ImageStreamCompleter loadBuffer(FireproofImage key, DecoderBufferCallback decode) {
   │                                                       ^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/fireproof_image_provider.dart

INFO: 'DecoderBufferCallback' is deprecated and shouldn't be used. Use ImageDecoderCallback with ImageProvider.loadImage instead. This feature was deprecated after v3.7.0-1.4.pre.

lib/src/fireproof_image_provider.dart:73:5

   ╷
73 │     DecoderBufferCallback decode,
   │     ^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/fireproof_image_provider.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
firebase_storage ^11.0.5 11.6.7 11.6.7
flutter flutter 0.0.0 0.0.0
hive ^2.2.3 2.2.3 2.2.3
hive_flutter ^1.1.0 1.1.0 1.1.0
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.3.23 1.3.23
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
fake_async - 1.3.1 1.3.1
ffi - 2.1.2 2.1.2
firebase_core - 2.25.5 2.25.5
firebase_core_platform_interface - 5.0.0 5.0.0
firebase_core_web - 2.11.5 2.11.5
firebase_storage_platform_interface - 5.1.10 5.1.10
firebase_storage_web - 3.7.1 3.7.1
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
http - 1.2.0 1.2.1
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
leak_tracker - 10.0.0 10.0.4
leak_tracker_flutter_testing - 2.0.1 3.0.3
leak_tracker_testing - 2.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
path_provider - 2.1.2 2.1.2
path_provider_android - 2.2.2 2.2.2
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.6.1 0.7.0
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
vm_service - 13.0.0 14.1.0
web - 0.4.2 0.5.0
win32 - 5.2.0 5.2.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

1
likes
120
pub points
10%
popularity

Publisher

verified publisherrideout.studio

Cache your Firebase Storage images to the Fireproof Closet for blazingly fast access.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

firebase_storage, flutter, hive, hive_flutter

More

Packages that depend on fireproof_closet