firefly 1.0.0
firefly: ^1.0.0 copied to clipboard

A small Flutter Firestore builder widget for clean widget trees.

1
likes
120 / 130
pub points
0 %
popularity

We analyzed this package on Aug 3, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 48 API elements (8.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 3 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:firefly/firefly.dart that imports:
  • package:firefly/src/firefly_provider.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, macOS, Web
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore^2.2.02.4.02.4.0
flutterflutter0.0.00.0.0
provider^5.0.05.0.05.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
cloud_firestore_platform_interface-5.3.05.3.0
cloud_firestore_web-2.3.02.3.0
collection-1.15.01.15.0
firebase_core-1.4.01.4.0
firebase_core_platform_interface-4.0.14.0.1
firebase_core_web-1.1.01.1.0
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.3.01.7.0
nested-1.0.01.0.0
plugin_platform_interface-2.0.12.0.1
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.

1
likes
120
pub points
0%
popularity

Publisher

isotop.se

A small Flutter Firestore builder widget for clean widget trees.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cloud_firestore, flutter, provider

More

Packages that depend on firefly