fireflutter 0.0.48
fireflutter: ^0.0.48 copied to clipboard

A free, open source, complete, rapid development package for creating Social apps, Chat apps, Community(Forum) apps, Shopping mall apps, and much more based on Firebase.

95
likes
90/ 130
pub points
67%
popularity

We analyzed this package on Nov 25, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 188 out of 386 API elements (48.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:fireflutter/fireflutter.dart that imports:
  • package:fireflutter/functions.dart that imports:
  • package:sign_in_with_apple/sign_in_with_apple.dart that declares support for platforms: Android, iOS, macOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
algolia^0.1.70.1.71.0.4
cloud_firestore^0.14.30.14.43.1.0
crypto^2.1.52.1.53.0.1
dio^3.0.103.0.104.0.4
firebase_auth^0.18.30.18.4+13.2.0
firebase_core^0.5.20.5.31.10.0
firebase_messaging^7.0.37.0.311.1.0
firebase_storage^5.0.15.2.010.1.0
flutterflutter0.0.00.0.0
flutter_facebook_auth^1.0.11.0.2+23.5.6
flutter_image_compress^0.7.00.7.01.1.0
geoflutterfire^2.2.12.2.13.0.1
google_sign_in^4.5.64.5.95.2.1
image_picker^0.6.7+140.6.7+220.8.4+4
location^3.1.03.2.44.3.0
merge_map^1.0.21.0.21.0.2
path^1.7.01.8.01.8.0
path_provider^1.6.241.6.282.0.7
permission_handler^5.0.1+15.1.0+28.3.0
rxdart^0.24.10.24.10.27.3
sign_in_with_apple^2.5.42.5.43.3.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
cloud_firestore_platform_interface-2.2.15.4.5
cloud_firestore_web-0.2.1+22.5.0
collection-1.15.01.15.0
convert-2.1.13.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
firebase_auth_platform_interface-2.1.46.1.4
firebase_auth_web-0.3.2+33.2.0
firebase_core_platform_interface-2.1.04.1.0
firebase_core_web-0.2.1+11.2.0
firebase_storage_platform_interface-1.0.24.0.6
firebase_storage_web-0.1.1+13.1.0
flutter_plugin_android_lifecycle-1.0.112.0.5
flutter_web_plugins-0.0.00.0.0
google_sign_in_platform_interface-1.1.22.1.0
google_sign_in_web-0.9.20.10.0+3
http-0.12.20.13.4
http_parser-3.1.44.0.0
image_picker_platform_interface-1.1.62.4.1
intl-0.16.10.17.0
js-0.6.30.6.3
location_platform_interface-1.1.02.3.0
location_web-1.0.13.1.1
matcher-0.12.110.12.11
meta-1.7.01.7.0
path_provider_linux-0.0.1+22.1.2
path_provider_macos-0.0.4+82.0.3
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.4
pedantic-1.11.11.11.1
permission_handler_platform_interface-2.0.23.7.0
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
quiver-2.1.53.0.1+1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.5
vector_math-2.1.02.1.1
win32-2.3.12.3.1
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 18 issues. Showing the first 2:

The constraint `^0.1.7` on algolia does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions algolia to update the constraint.

The constraint `^0.14.3` on cloud_firestore does not support the stable version `0.15.0`.

Try running dart pub upgrade --major-versions cloud_firestore to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

95
likes
90
pub points
67%
popularity

Publisher

sonub.com

A free, open source, complete, rapid development package for creating Social apps, Chat apps, Community(Forum) apps, Shopping mall apps, and much more based on Firebase.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

algolia, cloud_firestore, crypto, dio, firebase_auth, firebase_core, firebase_messaging, firebase_storage, flutter, flutter_facebook_auth, flutter_image_compress, geoflutterfire, google_sign_in, image_picker, location, merge_map, path, path_provider, permission_handler, rxdart, sign_in_with_apple

More

Packages that depend on fireflutter