firebase_validation 1.0.6

Flutter Android iOS

Plugin usado pela empresa CGI Software para validação de dados

3
likes
60 / 110
pub points
53 %
popularity

We analyzed this package on Oct 19, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 73 API elements (2.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:firebase_validation/app/page/firebase_validation.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:firebase_validation/app/page/firebase_validation.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:firebase_validation/app/page/firebase_validation.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:firebase_validation/app/page/firebase_validation.dart that declares support for platforms: Android, iOS

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:firebase_validation/app/page/firebase_validation.dart that imports:
  • package:firebase_validation/seguranca.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform iOS

Because:

  • package:firebase_validation/app/page/firebase_validation.dart that imports:
  • package:firebase_validation/seguranca.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
brasil_fields^0.4.00.4.00.4.0
cloud_firestore^0.13.70.13.70.14.1+3
device_info^0.4.2+40.4.2+90.4.2+9
dio^3.0.103.0.103.0.10
firebase_auth^0.16.10.16.10.18.1+2
flutterflutter0.0.00.0.0
flutter_html^1.0.21.0.21.0.2
font_awesome_flutter^8.8.18.10.08.10.0
intl^0.16.10.16.10.16.1
package_info^0.4.10.4.30.4.3
shared_preferences^0.5.80.5.12+20.5.12+2
url_launcher^5.5.35.7.55.7.5
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0-nullsafety.3
charcode-1.1.31.2.0-nullsafety.1
chewie-0.9.100.9.10
chewie_audio-1.0.0+11.0.0+1
cloud_firestore_platform_interface-1.1.22.1.2
cloud_firestore_web-0.1.1+20.2.0+4
collection-1.15.0-nullsafety.31.15.0-nullsafety.3
convert-2.1.12.1.1
css_colors-1.0.21.0.2
csslib-0.16.20.16.2
device_info_platform_interface-1.0.11.0.1
ffi-0.1.30.1.3
file-5.2.15.2.1
firebase-7.3.27.3.2
firebase_auth_platform_interface-1.1.82.1.1
firebase_auth_web-0.1.3+10.3.1+1
firebase_core-0.4.50.5.0+1
firebase_core_platform_interface-1.0.42.0.0
firebase_core_web-0.1.1+20.2.0
flutter_svg-0.18.10.19.1
flutter_web_plugins-0.0.00.0.0
html-0.14.0+40.14.0+4
http-0.12.20.12.2
http_parser-3.1.43.1.4
js-0.6.20.6.2
matcher-0.12.90.12.10-nullsafety.1
meta-1.3.0-nullsafety.31.3.0-nullsafety.4
open_iconic_flutter-0.3.00.3.0
path-1.7.01.8.0-nullsafety.1
path_drawing-0.4.1+10.4.1+1
path_parsing-0.1.40.1.4
path_provider_linux-0.0.1+20.0.1+2
path_provider_platform_interface-1.0.31.0.3
path_provider_windows-0.0.4+10.0.4+1
pedantic-1.9.21.9.2
petitparser-3.1.03.1.0
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
quiver-2.1.32.1.3
screen-0.0.50.0.5
shared_preferences_linux-0.0.2+20.0.2+2
shared_preferences_macos-0.0.1+100.0.1+10
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.1+10.0.1+1
sky_engine-0.0.990.0.99
source_span-1.7.01.8.0-nullsafety.2
stack_trace-1.9.51.10.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.1
term_glyph-1.1.01.2.0-nullsafety.1
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.3
url_launcher_linux-0.0.1+10.0.1+1
url_launcher_macos-0.0.1+80.0.1+8
url_launcher_platform_interface-1.0.81.0.8
url_launcher_web-0.1.4+10.1.4+1
url_launcher_windows-0.0.1+10.0.1+1
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.3
video_player-0.10.12+50.11.1+2
video_player_platform_interface-2.2.02.2.0
video_player_web-0.1.40.1.4
wakelock-0.1.4+20.2.0+1
webview_flutter-0.3.241.0.3
win32-1.7.31.7.3
xdg_directories-0.1.20.1.2
xml-4.5.14.5.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.7` on cloud_firestore does not support the latest published version `0.14.1+3`

pubspec.yaml:15:20

   ╷
15 │   cloud_firestore: ^0.13.7
   │                    ^^^^^^^
   ╵
The constraint `^0.16.1` on firebase_auth does not support the latest published version `0.18.1+2`

pubspec.yaml:16:18

   ╷
16 │   firebase_auth: ^0.16.1
   │                  ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs