firebase_validation 0.0.11

  • Readme
  • Changelog
  • Installing
  • 56

Firebase Validation #

Um pacote para validações do firebase da CGI;

Instalação #

  • Adicione o firebase_validation: 0.0.9 no pubspec.yaml do seu aplicativo.
  • Adicione os arquivos do google firebase no Android e iOS.
  • Rode flutter pub get

Uso #

Instancie a classe de configurações:

await Navigator.push(context,
    PageRouteBuilder(
        pageBuilder: (c, a1, a2) => ConfigPage(),
        transitionsBuilder: (c, anim, a2, child) =>
            FadeTransition(opacity: anim, child: child),
        transitionDuration: Duration(milliseconds: 100)));

Vocẽ pode passar alguns paramêtros se precisar:

ConfigPage(motorista: true, placa: true, filled: true)

Changelog #

Changed #

[0.0.11] - 02/07/2020 #

Added #

  • Informações do numero de devices
  • Informações do numero de usuários

[0.0.10] - 22/05/2020 #

Added #

  • Validação das configurações
  • Conexão com o firebase dentro da tela do plugin
  • Criado map de objeto do firebase para melhor organização

Chanded #

  • Snackbar aparecerá dentro da tela de configurações por 1s.
  • Não é necessário passar mais nenhum parametro na tela de instancia da tela de configurações.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  firebase_validation: ^0.0.11

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:firebase_validation/app/page/firebase_validation.dart';
import 'package:firebase_validation/app/page/politica.dart';
import 'package:firebase_validation/model/constants.dart';
import 'package:firebase_validation/model/firebase.dart';
import 'package:firebase_validation/seguranca.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
35
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
45
Overall:
Weighted score of the above. [more]
56
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform android

Because:

  • package:firebase_validation/app/page/firebase_validation.dart that declares support for platforms:

Package does not support Flutter platform ios

Because:

  • package:firebase_validation/app/page/firebase_validation.dart that declares support for platforms:

Package does not support Flutter platform linux

Because:

  • package:firebase_validation/app/page/firebase_validation.dart that declares support for platforms:

Package does not support Flutter platform macos

Because:

  • package:firebase_validation/app/page/firebase_validation.dart that declares support for platforms:

Package does not support Flutter platform web

Because:

  • package:firebase_validation/app/page/firebase_validation.dart that declares support for platforms:

Package does not support Flutter platform windows

Because:

  • package:firebase_validation/app/page/firebase_validation.dart that declares support for platforms:

Package not compatible with SDK dart

Because:

  • firebase_validation that is a package requiring null.

Health issues and suggestions

Document public APIs. (-0.11 points)

63 out of 65 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/app/page/firebase_validation.dart. (-0.50 points)

Analysis of lib/app/page/firebase_validation.dart reported 1 hint:

line 250 col 7: Avoid empty statements.

Maintenance issues and suggestions

Support latest dependencies. (-30 points)

The version constraint in pubspec.yaml does not support the latest published versions for 3 dependencies (cloud_firestore, firebase_auth, flutter_html).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and firebase_validation.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
cloud_firestore ^0.12.11 0.12.11 0.13.7
device_info ^0.4.1+3 0.4.2+4
firebase_auth ^0.15.1 0.15.5+3 0.16.1
flutter 0.0.0
flutter_html ^0.11.0 0.11.1 1.0.0
intl ^0.16.0 0.16.1
package_info ^0.4.0+12 0.4.1
shared_preferences ^0.5.4+8 0.5.8
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
csslib 0.16.1
file 5.2.1
firebase 7.3.0
firebase_auth_platform_interface 1.1.8
firebase_auth_web 0.1.3+1
firebase_core 0.4.5
firebase_core_platform_interface 1.0.4
firebase_core_web 0.1.1+2
flutter_web_plugins 0.0.0
html 0.14.0+3
http 0.12.1
http_parser 3.1.4
js 0.6.2
matcher 0.12.8
meta 1.1.8 1.2.1
path 1.7.0
path_provider_linux 0.0.1+2
path_provider_platform_interface 1.0.2
pedantic 1.9.0 1.9.1
platform 2.2.1
plugin_platform_interface 1.0.2
process 3.0.13
quiver 2.1.3
shared_preferences_linux 0.0.2+1
shared_preferences_macos 0.0.1+10
shared_preferences_platform_interface 1.0.4
shared_preferences_web 0.1.2+7
sky_engine 0.0.99
source_span 1.7.0
stack_trace 1.9.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
xdg_directories 0.1.0
Dev dependencies
flutter_test