firebase_ui 1.0.8

Flutter Android iOS

Firebase auth UI, dart package to mimic the firebaseUI(Google,Facebook,Twitter,Email supported)

15
likes
65 / 110
pub points
88 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 65 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:13:59

   ╷
13 │ <p>For help getting started with Flutter, view our online <a href="http://flutter.io/">documentation</a>.</p>
   │                                                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 138 API elements (5.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:firebase_ui/email_view.dart that imports:
  • package:firebase_ui/utils.dart that imports:
  • package:flutter_facebook_login/flutter_facebook_login.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:firebase_ui/email_view.dart that imports:
  • package:firebase_ui/utils.dart that imports:
  • package:google_sign_in/google_sign_in.dart that declares support for platforms: Android, iOS, Web
Package does not support Flutter platform Linux

Because:

  • package:firebase_ui/email_view.dart that imports:
  • package:firebase_ui/utils.dart that imports:
  • package:google_sign_in/google_sign_in.dart that declares support for platforms: Android, iOS, Web
Package does not support Flutter platform macOS

Because:

  • package:firebase_ui/email_view.dart that imports:
  • package:firebase_ui/utils.dart that imports:
  • package:google_sign_in/google_sign_in.dart that declares support for platforms: Android, iOS, Web
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/email_view.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/login_view.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_auth^0.14.0+50.14.0+90.18.0+1
flutterflutter0.0.00.0.0
flutter_facebook_login^3.0.03.0.03.0.0
flutter_twitter^1.1.21.1.31.1.3
google_sign_in^4.0.44.5.34.5.3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
firebase-7.3.07.3.0
firebase_core-0.4.50.5.0
firebase_core_platform_interface-1.0.42.0.0
firebase_core_web-0.1.1+20.2.0
flutter_web_plugins-0.0.00.0.0
google_sign_in_platform_interface-1.1.21.1.2
google_sign_in_web-0.9.20.9.2
http-0.12.20.12.2
http_parser-3.1.43.1.4
js-0.6.20.6.2
matcher-0.12.90.12.9
meta-1.1.81.2.3
path-1.7.01.7.0
pedantic-1.9.01.9.2
plugin_platform_interface-1.0.21.0.2
quiver-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.14.0+5` on firebase_auth does not support the latest published version `0.18.0+1`

pubspec.yaml:16:18

   ╷
16 │   firebase_auth: ^0.14.0+5
   │                  ^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

15
likes
65
pub points
88%
popularity

Firebase auth UI, dart package to mimic the firebaseUI(Google,Facebook,Twitter,Email supported)

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

crucifixx25@gmail.com

License

MIT (LICENSE)

Dependencies

firebase_auth, flutter, flutter_facebook_login, flutter_twitter, google_sign_in

More

Packages that depend on firebase_ui