firebase_ui 1.0.8

  • Readme
  • Changelog
  • Example
  • Installing
  • 90

firebase_ui #

Build Status pub package

Fork of https://pub.dartlang.org/packages/flutter_firebase_ui

Old package wasnt being maintained so i created this one to update.

firebase_ui is a library that helps you to quickly implement firebase authentication. It provides UI for the common identity providers like Facebook, Google, Twitter and email.

Note: this plugin use firebase_auth you must configure it as describe here.

screenshot

screenshot

Show firebase ui example.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[1.0.8] - 02/10/2019

  • update dependencies

[1.0.7] - 21/5/2019

  • fixed padding

[1.0.6] - 21/5/2019

  • added better padding options
  • swapped listView for a column
  • changed twitter cancel error message

[1.0.5] - 21/5/2019

  • update dependencies
  • fixing twitter

[1.0.1] - 29/4/2019

  • update dependencies
  • added custon padding to buttoms
  • added avoidBottomInset

[0.0.19] - 19/12/2018

  • update dependencies
  • added show/hide app barq

[0.0.13] - 19/12/2018

  • update dependencies
  • add twitter

[0.0.12] - 27/09/2018

  • after trouble sign in pop

[0.0.11] - 27/09/2018

  • add function signOutProviders

[0.0.10] - 26/09/2018

  • fixed empty null on Providers
  • allow for usage with landscape orientation

[0.0.9] - 07/09/2018

  • add mail verification option

[0.0.8] - 17/07/2018

  • improve UI

[0.0.7] - 04/07/2018

  • fixe sign in with mail

[0.0.6] - 30/05/2018

  • improve show dialog error

[0.0.5] - 29/05/2018

  • show error occured on unknown errors
  • display email if no displayName (example)
  • secure providers test, firebase_auth behavior change
  • pop sign up !

[0.0.4] - 09/05/2018

  • Upgrade to Google Services 3.2.1 and Google Sign In 3.0.3

[0.0.3] - 23/03/2018

  • dart 2 fix

[0.0.2] - 20/03/2018

  • improve ui
  • change firebase_auth version

[0.0.1] - 19/03/2018

  • initial release

example/README.md

firebase_ui #

A new Flutter project.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  firebase_ui: ^1.0.8

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:firebase_ui/email_view.dart';
import 'package:firebase_ui/flutter_firebase_ui.dart';
import 'package:firebase_ui/l10n/localization.dart';
import 'package:firebase_ui/l10n/translations.dart';
import 'package:firebase_ui/login_view.dart';
import 'package:firebase_ui/password_view.dart';
import 'package:firebase_ui/sign_up_view.dart';
import 'package:firebase_ui/trouble_signin.dart';
import 'package:firebase_ui/utils.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
85
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
90
Learn more about scoring.

We analyzed this package on Nov 19, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/email_view.dart.

Run flutter format to format lib/email_view.dart.

Format lib/login_view.dart.

Run flutter format to format lib/login_view.dart.

Format lib/utils.dart.

Run flutter format to format lib/utils.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (firebase_auth).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
firebase_auth ^0.14.0+5 0.14.0+9 0.15.0
flutter 0.0.0
flutter_facebook_login ^3.0.0 3.0.0
flutter_twitter ^1.1.2 1.1.3
google_sign_in ^4.0.4 4.0.14
Transitive dependencies
collection 1.14.11 1.14.12
firebase_core 0.4.1+5
google_sign_in_platform_interface 1.0.0
meta 1.1.7 1.1.8
quiver_hashcode 2.0.0
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test