firebase_helpers 0.3.1
firebase_helpers: ^0.3.1 copied to clipboard

A package that provides various Google Firebase related services helpers. Provides helpers to perform queries on firestore, firebase auth etc.

12
likes
100 / 130
pub points
89 %
popularity

We analyzed this package on Apr 22, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 36 out of 39 API elements (92.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:firebase_helpers/firebase_helpers.dart that imports:
  • package:firebase_storage/firebase_storage.dart that imports:
  • package:firebase_storage_platform_interface/firebase_storage_platform_interface.dart that imports:
  • package:firebase_storage_platform_interface/src/platform_interface/platform_interface_reference.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/firestore_service.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore^1.0.21.0.61.0.6
firebase_storage^8.0.08.0.48.0.4
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.5.02.5.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
cloud_firestore_platform_interface-4.0.24.0.2
cloud_firestore_web-1.0.61.0.6
collection-1.15.01.15.0
firebase_core-1.0.41.0.4
firebase_core_platform_interface-4.0.04.0.0
firebase_core_web-1.0.21.0.2
firebase_storage_platform_interface-2.0.22.0.2
firebase_storage_web-1.0.41.0.4
flutter_web_plugins-0.0.00.0.0
http-0.13.10.13.1
http_parser-4.0.04.0.0
js-0.6.30.6.3
meta-1.3.01.3.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
plugin_platform_interface-2.0.02.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

12
likes
100
pub points
89%
popularity

Publisher

dlohani.com.np

A package that provides various Google Firebase related services helpers. Provides helpers to perform queries on firestore, firebase auth etc.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cloud_firestore, firebase_storage, flutter

More

Packages that depend on firebase_helpers