firebase_dart 1.0.0-dev.46
firebase_dart: ^1.0.0-dev.46 copied to clipboard

A port of the Firebase database, auth and storage client to pure Dart code, usable on different platforms

12
likes
100/ 130
pub points
83%
popularity

We analyzed this package on Oct 5, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 399 out of 660 API elements (60.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:firebase_dart/firebase_dart.dart that imports:
  • package:firebase_dart/implementation/pure_dart.dart that imports:
  • package:firebase_dart/src/auth/authhandlers.dart that imports:
  • package:firebase_dart/src/implementation/isolate.dart that imports:
  • package:firebase_dart/src/implementation/isolate/util.dart that imports:
  • dart:isolate
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 36 issues. Showing the first 2:

lib/auth.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/core.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
_discoveryapis_commons^1.0.01.0.21.0.2
async^2.5.02.8.22.8.2
clock^1.1.01.1.01.1.0
collection^1.15.01.15.01.15.0
crypto^3.0.03.0.13.0.1
expressions^0.2.20.2.30.2.3
googleapis>=2.0.0 <4.0.03.0.05.0.1
googleapis_auth^1.1.01.1.01.1.0
hive^2.0.02.0.42.0.4
http^0.13.00.13.40.13.4
jose^0.3.20.3.20.3.2
js^0.6.30.6.30.6.3
logging^1.0.01.0.21.0.2
meta^1.3.01.7.01.7.0
openid_client^0.4.00.4.30.4.3
pedantic^1.11.01.11.11.11.1
quiver^3.0.03.0.13.0.1
rxdart^0.27.00.27.20.27.2
sortedmap^0.5.10.5.10.5.1
stream_channel^2.1.02.1.02.1.0
synchronized^3.0.03.0.03.0.0
uuid^3.0.13.0.43.0.4
web_socket_channel^2.0.02.1.02.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.02.3.0
asn1lib-1.0.21.0.2
charcode-1.3.11.3.1
convert-3.0.13.0.1
crypto_keys-0.3.00.3.0
http_parser-4.0.04.0.0
matcher-0.12.110.12.11
path-1.8.01.8.0
petitparser-4.3.04.3.0
pointycastle-3.3.43.3.4
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
x509-0.2.20.2.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=2.0.0 <4.0.0` on googleapis does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions googleapis to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.2, Dart 2.14.2.