firebase_cloud_messaging_backend 1.0.1 icon indicating copy to clipboard operation
firebase_cloud_messaging_backend: ^1.0.1 copied to clipboard

Use Firebase Cloud Messaging in your dart server code

6
likes
85/ 140
pub points
23%
popularity

We analyzed this package 4 days ago, and awarded it 85 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
15 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in README.md should be secure. 1 link is insecure.

README.md:34:49

   ╷
34 │ <p>Please file feature requests and bugs at the <a href="http://example.com/issues/replaceme">issue tracker</a>.</p>
   │                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 87 out of 192 API elements (45.3 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:firebase_cloud_messaging_backend/firebase_cloud_messaging_backend.dart that imports:
  • package:firebase_cloud_messaging_backend/src/logic/JWTClaim.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 63 issues. Showing the first 2:

INFO: Name source files using lowercase_with_underscores.

To reproduce make sure you are using the lints_core and run dart analyze lib/src/FirebaseCloudMessagingServer.dart

INFO: 'List.List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/FirebaseCloudMessagingServer.dart:44:34

   ╷
44 │     List<ServerResult> results = List();
   │                                  ^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/FirebaseCloudMessagingServer.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
googleapis_auth^0.2.100.2.12+11.3.1
http^0.12.0+20.12.20.13.5
json_annotation^3.0.03.1.14.7.0
json_serializable^3.2.23.5.26.5.4
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.050.0.0
analyzer-1.7.25.2.0
args-2.3.12.3.1
async-2.10.02.10.0
build-2.3.12.3.1
build_config-0.4.71.1.1
charcode-1.3.11.3.1
checked_yaml-1.0.42.0.1
cli_util-0.3.50.3.5
collection-1.17.01.17.0
convert-3.1.13.1.1
crypto-3.0.23.0.2
dart_style-2.1.12.2.4
file-6.1.46.1.4
glob-2.1.12.1.1
http_parser-3.1.44.0.2
logging-1.1.01.1.0
meta-1.8.01.8.0
package_config-2.1.02.1.0
path-1.8.21.8.2
pedantic-1.11.11.11.1
pub_semver-2.1.32.1.3
pubspec_parse-0.1.81.2.1
source_gen-0.9.10+51.2.6
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
watcher-1.0.21.0.2
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint ^0.2.10 on googleapis_auth does not support the stable version 1.0.0.

Try running dart pub upgrade --major-versions googleapis_auth to update the constraint.

The constraint ^0.12.0+2 on http does not support the stable version 0.13.0.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.4.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Dart 2.18.4.

6
likes
85
pub points
23%
popularity

Publisher

verified publisher iconpdad.de

Use Firebase Cloud Messaging in your dart server code

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

googleapis_auth, http, json_annotation, json_serializable

More

Packages that depend on firebase_cloud_messaging_backend