firebase_admin 0.3.0-dev.4 copy "firebase_admin: ^0.3.0-dev.4" to clipboard
firebase_admin: ^0.3.0-dev.4 copied to clipboard

A port of the Firebase admin sdk to pure, idiomatic Dart code

85
likes
120/ 140
pub points
93%
popularity

We analyzed this package 5 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected licenses: Apache-2.0, BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

164 out of 231 API elements (71.0 %) have documentation comments.

Some symbols that are missing documentation: firebase_admin, firebase_admin.AccessToken.expirationTime, firebase_admin.Auth.delete, firebase_admin.CreateMultiFactorInfoRequest.CreateMultiFactorInfoRequest.phone, firebase_admin.Credentials.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:firebase_admin/firebase_admin.dart that imports:
  • package:firebase_admin/src/credential.dart that imports:
  • package:firebase_admin/src/auth/credential.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: Dangling library doc comment.

lib/src/utils/validator.dart:1:1

  ╷
1 │ /// Validates that a string is a valid email.
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/utils/validator.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
_discoveryapis_commons ^1.0.4 1.0.6 1.0.6
clock ^1.1.0 1.1.1 1.1.1
collection ^1.15.0 1.18.0 1.18.0
crypto_keys ^0.3.0 0.3.0+1 0.3.0+1
dotenv ^4.0.0 4.2.0 4.2.0
firebase_dart ^1.0.10 1.1.3 1.1.3
firebaseapis ^0.1.2 0.1.2 0.2.0
gcloud ^0.8.0 0.8.12 0.8.12
googleapis ^9.2.0 9.2.0 12.0.0
http ^0.13.0 0.13.6 1.2.1
jose ^0.3.2 0.3.4 0.3.4
meta ^1.4.0 1.12.0 1.12.0
openid_client ^0.4.3 0.4.8 0.4.8
path ^1.8.0 1.9.0 1.9.0
snapshot ^0.2.5 0.2.6 0.2.6
x509 ^0.2.2 0.2.4+2 0.2.4+2
Transitive dependencies
Package Constraint Compatible Latest
args - 2.4.2 2.4.2
asn1lib - 1.5.2 1.5.2
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
expressions - 0.2.5+1 0.2.5+1
fixnum - 1.1.0 1.1.0
hive - 2.2.3 2.2.3
http_parser - 4.0.2 4.0.2
intl - 0.17.0 0.19.0
js - 0.6.7 0.7.1
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
petitparser - 6.0.2 6.0.2
pointycastle - 3.7.4 3.7.4
quiver - 3.2.1 3.2.1
retry - 3.1.2 3.1.2
rxdart - 0.27.7 0.27.7
sortedmap - 0.5.3 0.5.3
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.0
typed_data - 1.3.2 1.3.2
uuid - 4.3.3 4.3.3
web - 0.5.0 0.5.0
web_socket_channel - 2.4.4 2.4.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.1.2` on firebaseapis does not support the stable version `0.2.0`.

Try running dart pub upgrade --major-versions firebaseapis to update the constraint.

The constraint `^9.2.0` on googleapis does not support the stable version `10.0.0`.

Try running dart pub upgrade --major-versions googleapis to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Dart 3.3.0.

Check the analysis log for details.